Bug 836385 - slapi_ldap_bind() doesn't check bind results
slapi_ldap_bind() doesn't check bind results
Status: CLOSED DUPLICATE of bug 836386
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 17:42 EDT by Nathan Kinder
Modified: 2012-07-02 16:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 16:14:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2012-06-28 17:42:07 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/399

The slapi_ldap_bind() function does not properly check the bind operation results.  It currently only calls ldap_parse_result() if returnedctrls was passed in by the caller.  We need to call ldap_parse_result() even if we don't need to get the returned controls, as it's how we get the LDAP response code for the BIND operation.  With the current code, slapi_ldap_bind() will end up returning 0 for a failed BIND operation if returnedctrls is not passed in.
Comment 2 Nathan Kinder 2012-07-02 16:14:38 EDT

*** This bug has been marked as a duplicate of bug 836386 ***

Note You need to log in before you can comment on or make changes to this bug.