Bug 836399 - Plugging iPhone via USB breaks laptop battery recognition/charging
Plugging iPhone via USB breaks laptop battery recognition/charging
Status: CLOSED DUPLICATE of bug 834359
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sven Lankes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 20:10 EDT by Nadim Kobeissi
Modified: 2012-07-02 04:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 04:12:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadim Kobeissi 2012-06-28 20:10:33 EDT
Description of problem:
When I plug in my iPhone (to tether to its 3G connection) Fedora stops charging my laptop's battery. If I turn on my laptop with my iPhone already plugged in, the battery is not even recognized and power management settings and other parts of Fedora behave as if I am using a desktop. My laptop is a Lenovo Thinkpad X230.

Version-Release number of selected component (if applicable):
Fedora 17.


Steps to Reproduce:
1. Plug in iPhone for tethering
2. Watch as battery stops charging
3. Reboot with iPhone plugged in to see battery recognition disappear
  
Actual results:
Battery charges and is recognized normally even with iPhone plugged in.


Expected results:
Battery does not charge if iPhone is plugged in and is not recognized upon reboot if iPhone is still plugged in.

Additional info:
iPhone 4S.
Comment 1 Nadim Kobeissi 2012-06-28 20:13:21 EDT
Mixed up 'Actual results' and 'Expected results,' sorry!
Comment 2 Gwyn Ciesla 2012-06-28 21:33:12 EDT
When I plug in my iPod touch to my desktop, I get the following in dmesg:

[76869.103686] upowerd[21436]: segfault at 0 ip 00000030bc706720 sp 00007fff821229d8 error 4 in libc-2.15.so[30bc600000+1ac000]

The iPod is then not mounted.

This might not be a poweradmin bug.
Comment 3 Nadim Kobeissi 2012-06-28 22:27:24 EDT
OK. I've changed this into a upower bug. 

In my case, the iPhone is in fact mounted, although I do get these messages in dmesg:


[ 1700.237262] ipheth 1-1.2:4.2: Apple iPhone USB Ethernet device attached
[ 1701.265492] upowerd[3030]: segfault at 0 ip 00000033a0106720 sp 00007fffdfc54c98 error 4 in libc-2.15.so[33a0000000+1ac000]
[ 1701.749343] iphone-set-info[3823]: segfault at 0 ip 00000033a0106720 sp 00007fff24637f28 error 4 in libc-2.15.so[33a0000000+1ac000]
Comment 4 Richard Hughes 2012-07-02 04:12:57 EDT

*** This bug has been marked as a duplicate of bug 834359 ***

Note You need to log in before you can comment on or make changes to this bug.