Bug 836408 - en-US needs to be set up on the server even when not using this language.
en-US needs to be set up on the server even when not using this language.
Status: CLOSED DUPLICATE of bug 707102
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
1.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 21:17 EDT by Carlos Munoz
Modified: 2013-03-03 21:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 00:57:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2012-06-28 21:17:31 EDT
Description of problem:
Attempting to push pot sources in a language other than English fails if en-US is not configured on the server. 

Version-Release number of selected component (if applicable):
Reported against 1.5, but also present in 1.6

How reproducible:
Always


Steps to Reproduce:
1. Configure a Zanata instance with languages other than en-US.
2. In zanata.xml, configure zanata.sourceLang to something other than en-US.
3. Try to push sources using the python or maven client.
  
Actual results:
With the maven client, the following error is reported:
Failed to execute goal org.zanata:zanata-maven-plugin:1.6.1-SNAPSHOT:push (default-cli) on project test: Zanata mojo exception: operation returned 403 (Forbidden): Locale en-US is not enabled on this server. Please contact admin., uri: http://XXXX/zanata/rest/projects/p/test/iterat
ions/i/1.0/r, annotations: [@javax.ws.rs.PUT(), @javax.ws.rs.Path(value={id})] -> [Help 1]


Expected results:
Zanata should allow the push of the source files.

Additional info:
If en-US is configured, the source files are pushed successfully.
Bug originally reported by a community user.
Comment 1 Sean Flanigan 2012-07-03 00:57:16 EDT

*** This bug has been marked as a duplicate of bug 707102 ***

Note You need to log in before you can comment on or make changes to this bug.