Bug 836415 - Run V7 cert with RHEL 5.8 Panic on 4TB memory X86_64 [NEEDINFO]
Run V7 cert with RHEL 5.8 Panic on 4TB memory X86_64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 22:18 EDT by Ethan
Modified: 2014-06-02 09:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:02:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (ethan.zhao)


Attachments (Terms of Use)

  None (edit)
Description Ethan 2012-06-28 22:18:44 EDT
Description of problem:
RHEL5.8 Panic and reboot while running V7 cert on 4TB memory X86_64.

Version-Release number of selected component (if applicable):

RHEL5.8 with V7 cert tool

How reproducible:

Steps to Reproduce:
1.install rhel5.8 and boot with base kernel (non-xen)
2.install rhel v7 certkit 1.4.38  http://10.113.220.134/changjiang_export/share/susie/Cert_Toolkit/RHEL-cert/v7/RHEL5/v7-1.4.38/
3.run v7 memory test by "v7 run --test=memory"
  
Actual results:
 System panic and reboot
Expected results:
 Should not panic and reboot.
Additional info:

 Using REDHAT latest cert tool v7-1.5-28-RC,still met this issue.

NMI Watchdog detected LOCKUP on CPU 12
CPU 12
Modules linked in: ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERAD                                                                                                                     E iptable_nat ip_nat xt_state ip_conntrack nfnetlink ipt_REJECT xt_tcpudp iptabl                                                                                                                     e_filter ip_tables x_tables bridge autofs4 hidp rfcomm l2cap bluetooth lockd sun                                                                                                                     rpc cpufreq_ondemand acpi_cpufreq freq_table mperf be2iscsi ib_iser rdma_cm ib_c                                                                                                                     m iw_cm ib_sa ib_mad ib_addr iscsi_tcp bnx2i cnic ipv6 xfrm_nalgo crypto_api uio                                                                                                                      cxgb3i libcxgbi iw_cxgb3 ib_core cxgb3 libiscsi_tcp libiscsi2 scsi_transport_is                                                                                                                     csi2 scsi_transport_iscsi dm_multipath scsi_dh video backlight sbs power_meter h                                                                                                                     wmon i2c_ec dell_wmi wmi button battery asus_acpi acpi_memhotplug ac parport_pc                                                                                                                      lp parport ksm(U) kvm_intel(U) kvm(U) joydev igb tpm_tis tpm 8021q i2c_i801 tpm_                                                                                                                     bios i7core_edac i2c_core dca edac_mc sg pcspkr dm_raid45 dm_message dm_region_h                                                                                                                     ash dm_mem_cache dm_snapshot dm_zero dm_mirror dm_log dm_mod ahci libata shpchp                                                                                                                      megaraid_sas sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd
Pid: 4375, comm: threaded_memtes Tainted: G     ---- 2.6.18-308.el5 #1
RIP: 0010:[<ffffffff80064bdf>]  [<ffffffff80064bdf>] .text.lock.spinlock+0x5/0x3                                                                                                                     0
RSP: 0000:ffff8180063e9cc0  EFLAGS: 00000086
RAX: 000000000000000c RBX: ffff818080155340 RCX: 000000000000001f
RDX: 0000000000000000 RSI: 00000000000027ec RDI: ffff818080001e48
RBP: 0000000000000282 R08: 0000000000000000 R09: 0000000006a70eda
R10: 0000000000000000 R11: 0000000000000002 R12: 0000000000000000
R13: ffff818080001600 R14: ffff818080003c10 R15: 0000000000000000
FS:  00002af95cfdd940(0000) GS:ffff818080155440(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00002b32c7258000 CR3: 000000fff4767000 CR4: 00000000000026a0
Process threaded_memtes (pid: 4375, threadinfo ffff8180063e8000, task ffff818069                                                                                                                     c01100)
Stack:  ffffffff8000a90b 0000000000000000 0000004400000000 ffff818080003c10
 00000002000280d2 0000000100000000 0000000000000001 000000000000001f
 ffff818080003c10 00000000000280d2 ffff818080003c10 ffff818069c01100
Call Trace:
 [<ffffffff8000a90b>] get_page_from_freelist+0x129/0x442
 [<ffffffff8000f419>] __alloc_pages+0x78/0x308
 [<ffffffff80008ead>] __handle_mm_fault+0x73e/0x103b
 [<ffffffff80064b30>] _spin_unlock_irqrestore+0x8/0x9
 [<ffffffff80067202>] do_page_fault+0x499/0x842
 [<ffffffff80063002>] thread_return+0x62/0xfe
 [<ffffffff8005dde9>] error_exit+0x0/0x84


Code: 7e f9 e9 7f fe ff ff f3 90 83 3f 00 7e f9 e9 f9 fe ff ff f3
Kernel panic - not syncing: nmi watchdog
 WARNING: at kernel/panic.c:137 panic()

Call Trace:
 <NMI>  [<ffffffff80093abe>] panic+0x1c6/0x1d7
 [<ffffffff8006c593>] _show_stack+0xdb/0xea
 [<ffffffff8006c686>] show_registers+0xe4/0x100
 [<ffffffff800652a5>] die_nmi+0x66/0xa3
 [<ffffffff80065a66>] nmi_watchdog_tick+0x157/0x1d3
 [<ffffffff80065609>] default_do_nmi+0x81/0x21d
 [<ffffffff800658f1>] do_nmi+0x43/0x61
 [<ffffffff80064ecf>] nmi+0x7f/0x88
 [<ffffffff80064bdf>] .text.lock.spinlock+0x5/0x30
 <<EOE>>  [<ffffffff8000a90b>] get_page_from_freelist+0x129/0x442
 [<ffffffff8000f419>] __alloc_pages+0x78/0x308
 [<ffffffff80008ead>] __handle_mm_fault+0x73e/0x103b
 [<ffffffff80064b30>] _spin_unlock_irqrestore+0x8/0x9
 [<ffffffff80067202>] do_page_fault+0x499/0x842
 [<ffffffff80063002>] thread_return+0x62/0xfe
 [<ffffffff8005dde9>] error_exit+0x0/0x84
Comment 1 Ethan 2012-06-28 22:24:45 EDT
Not meet the same issue with RHEL62, need some back porting on 5.x ?
Comment 2 RHEL Product and Program Management 2014-03-07 07:39:57 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:02:59 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.