Bug 836432 - [Alll Lang][fonts-tweek-tool][Feature-Request] - Multiple language deletion at a time should be enabled
[Alll Lang][fonts-tweek-tool][Feature-Request] - Multiple language deletion a...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fonts-tweak-tool (Show other bugs)
17
All Linux
low Severity low
: ---
: ---
Assigned To: James Ni
Fedora Extras Quality Assurance
: i18n, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 01:38 EDT by Satyabrata Maitra
Modified: 2012-07-04 02:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-04 02:11:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2012-06-29 01:38:20 EDT
Description of problem:
Suppose user selected 10 languages and those are showing in the selected language list. Now, in current scenario, user needs to delete one language at a time. The multiple languages can not be selected with SHIFT or CTRL key press when makes seleciton or neither can be deleted together at a time. This feature should be developed to provide user more flexibility.

Version-Release number of selected component (if applicable):
fonts-tweak-tool-0.0.5-1.fc17.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Open fonts-tweak-tool
2. Select multiple languages from the language list one at a time.
3. Try to select multiple languages from the selected lanauage list and delete.
  
Actual results:
Multiple lanauage selection is not provided,hence can not be deleted together either.

Expected results:
This feature should be develped.

Additional info:
Comment 1 Jens Petersen 2012-06-29 03:39:21 EDT
I dunno - the UI seems in line with other Gnome control-center language settings, etc.  I am not sure if there is a strong enough use-case for this.

Typically I would only expect users to have a few languages configured in fonts-tweak-tool.
Comment 2 Jens Petersen 2012-06-29 03:42:17 EDT
But if you have some comparable examples in mind - could you attach a screenshot perhaps?
Comment 3 Akira TAGOH 2012-06-29 04:13:42 EDT
Or selecting "Default" as the language may works enough in most cases, which will be available in fonts-tweak-tool-0.0.6 + libeasyfc-0.7
Comment 4 Satyabrata Maitra 2012-07-02 04:05:15 EDT
Hi Jens && Tagoh

The current limitation is : user can not select multiple languages to add, nor can delete the added languages in a single attempt either, in fonts-tweak-tool.
We obviously expect users to have fewer languages configured, but enabling this popular multi-select (if can be selected together, can be added, or deleted together as well) option, I hope we can provide them a better option at the same time. In my opinion, although, its not something critical, but still, we should not restrict the user's expectation. :) Whats your opinion?
Comment 5 Akira TAGOH 2012-07-02 06:56:18 EDT
Removing multi-selected items somewhat makes sense to me though, as this UI is following up the standard UI in GNOME, you may better try to find out if GNOME upstream allows it that way.  Aside from that, fonts-tweak-tool also has another action after adding say. so need to think about what to do after adding/removing multiple items too.  honestly I don't see any useful for adding multiple languages at once, because they need to re-select a single item after that. I don't think it's better UI then. plus, then partially allowing multiple selection is also bad UX. hence, I think current UI is better.
Comment 6 Satyabrata Maitra 2012-07-03 04:32:51 EDT
Hi Tagoh

Thanks for your opinion. I am confused with your first sentence and the last one. :) Anyway, if the sentence, "because they need to re-select a single item after that" is the fact, then, I can suggest one thing and that is, we should not allow user/restrict user to add or select single or multiple languages, when one is already selected and showing on the list after "Default". And, once user removes the selected language, the fresh language selection can be enabled again. What you suggest?
Comment 7 Akira TAGOH 2012-07-03 05:48:43 EDT
I meant I don't see any useful for adding/modifying fonts on multiple languages. to keep consistency on the behavior, supporting it for only removing isn't a good idea. that's it.

What's the use-case you want to do so? and what applications/tools does it do as you expected?
Comment 8 Satyabrata Maitra 2012-07-04 01:57:48 EDT
Ah! I got your point. As far as the UI design is concern, multiple selection from a list is a UI concept, but, yes, as per the GNOME3 UI standard, this is not considered. I checked out with gnome-control-center region app as well, there also, multiple selection of languages with SHIFT/CTRL key, not provided. So, I think, as of now, we can not go beyond the current standard. Jens and Tagoh, so, I think, we can close this bug with wontfix resolution, is it ok for you?

Note You need to log in before you can comment on or make changes to this bug.