Bug 836476 - Provide native systemd service
Summary: Provide native systemd service
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: trousers (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 820163 (view as bug list)
Depends On:
Blocks: 751869
TreeView+ depends on / blocked
 
Reported: 2012-06-29 08:11 UTC by Tomasz Torcz
Modified: 2012-09-17 22:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 22:19:10 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcsd.service (157 bytes, application/octet-stream)
2012-06-29 08:11 UTC, Tomasz Torcz
no flags Details

Description Tomasz Torcz 2012-06-29 08:11:27 UTC
Created attachment 595228 [details]
tcsd.service

Description of problem:

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Please ship attached unit file and drop SysV init script.

Systemd unit does not load modules - this belongs to kernel's autoloading mechanism.

Comment 1 Fedora Update System 2012-08-27 17:37:10 UTC
trousers-0.3.9-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/trousers-0.3.9-3.fc18

Comment 2 Tomasz Torcz 2012-08-27 18:04:40 UTC
Thanks for taking unit, two notes:

1) in F18 you can utilize systemd macros in .spec file - http://cgit.freedesktop.org/systemd/systemd/tree/src/core/macros.systemd.in
and http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Macroized_scriptlets_.28Fedora_18.2B.29

2) kernel modules. SYSV scripts explicitly loads tpm modules. This should be auto-loaded by kernel, but I'm not 100% sure if kernel does that. If not, then until kernel is fixed, you would have to ship /etc/modules-load.d/tpm.conf file containing:

tpm
tpm_bios
tpm_tis
tpm_atmel
tpm_infineon
tpm_nsc

i.e. all tpm kernel modules shipped with fedora.

Comment 3 Steve Grubb 2012-08-27 18:26:33 UTC
I'll update the macros next time. I was thinking I would be doing builds on F17, but I guess i can't.

All systems I've see with a tpm chip create a /dev/tpm0 during boot. The init script haven't been changed since originally written other than some reformatting. In that time I think things have changed. I also have bug reports saying it couldn't load a module.So, for now I want to see if the kernel loads everything and then add stuff as its determined its needed.

Comment 4 Fedora Update System 2012-08-28 18:14:58 UTC
Package trousers-0.3.9-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing trousers-0.3.9-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12846/trousers-0.3.9-3.fc18
then log in and leave karma (feedback).

Comment 5 Steve Grubb 2012-08-29 14:39:41 UTC
*** Bug 820163 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2012-09-17 22:19:10 UTC
trousers-0.3.9-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.