Bug 836484 - [whql][Netkvm] Job of "NDISTest6.5-[2 Machine]-VlanSendRecv" failed on HCK for win2k8-32
[whql][Netkvm] Job of "NDISTest6.5-[2 Machine]-VlanSendRecv" failed on HCK fo...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
: 915182 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 04:28 EDT by dawu
Modified: 2014-07-11 02:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 04:15:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Job1070FailedError (32.88 KB, application/octet-stream)
2012-06-29 04:29 EDT, dawu
no flags Details

  None (edit)
Description dawu 2012-06-29 04:28:41 EDT
Description of problem:
Job 1070 of "NDISTest6.5-[2 Machine]-VlanSendRecv" failed on HCK for win2k8-32

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29


How reproducible:
always

Steps to Reproduce:

1. Boot guest with CLI:

/usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-32-nic1.raw,if=none,format=raw,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:10:06:06:49:10,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:10:06:06:49:11,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:10:06:16:49:12,bus=pci.0,addr=0x6 -uuid f661f828-9f97-4a87-a38b-161ae882a8c5 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-32-nic1,server,nowait -mon chardev=111a,mode=readline -spice disable-ticketing,port=5931 -vga qxl -bios /usr/share/seabios/bios-pm.bin -monitor stdio

2. Run job 1070 of "NDISTest6.5-[2 Machine]-VlanSendRecv".

3. Run task "Run NDISTest Client"

  
Actual results:
Task "Run NDISTest Client" failed to start and whole job finally failed.

Expected results:
Task "Run NDISTest Client" should start normally and pass without any error.

Additional info:
No any HCK logs to available, only HCK error for task "Run NDISTest Client" can be provide,please refer to the attached "Job1070FailedError.wtl" for details.
Comment 1 dawu 2012-06-29 04:29:42 EDT
Created attachment 595231 [details]
Job1070FailedError
Comment 2 dawu 2012-06-29 04:32:33 EDT
This issue only found on win2k8-32, it didn't reproduce on other os.
Comment 4 ybendito 2012-08-21 17:16:21 EDT
Please run DebugView (enable Win32 + Kernel + Verbose Kernel) and then run this test, save the output and attch to the bug.
Thanks.
Comment 5 Mike Cao 2012-08-21 22:39:44 EDT
Dawu ,pls retest it according to comment #4
Comment 6 dawu 2012-08-22 01:33:16 EDT
(In reply to comment #4)
> Please run DebugView (enable Win32 + Kernel + Verbose Kernel) and then run
> this test, save the output and attch to the bug.
> Thanks.

please refer to the attached of "bug836484.LOG" for details.

Best Regards,
Dawn
Comment 7 dawu 2012-08-22 01:34:37 EDT
Created attachment 606129 [details]
bug836484.LOG
Comment 8 ybendito 2012-08-22 16:14:59 EDT
I assume the problem happens on RTM WHCK 9200.
If you did not try it yet, please try running this specific test with off-line NDIS test (machine-to-machine, without controller).

If you do not know how to do it, please let us know we'll send all the instructions.
Comment 9 dawu 2012-08-22 22:58:04 EDT
(In reply to comment #8)
> I assume the problem happens on RTM WHCK 9200.
> If you did not try it yet, please try running this specific test with
> off-line NDIS test (machine-to-machine, without controller).
> 
> If you do not know how to do it, please let us know we'll send all the
> instructions.

Hi ybendito,

Could you send me all the instructions since I don't know how to run RTM WHCK 9200 without controller? 

Thanks!
Best Regards,
Dawn
Comment 10 ybendito 2012-08-23 16:52:03 EDT
On controller machine (when you access it from the client machine with DTM User account), there is "Tests" network share (pointing to Tests folder under Program Files(x86)\Windows Kits\8.0\WHCK... x86|x64 ...
Please locate there an NDIS folder, under it NdisTest folder (contains NDIS 6.0 test engine) and NdisTest.net folder (contains NDIS 6.5 engine)
Copy complete NdisTest.net folder to "client" machine and to "server" machine.
Locate ndistest.exe and run it on both machines (as administrator, if needed).

Run dbgview to collect traces in case the test fails.
On server machine select "Server", select RH adapter as support device, Intel adapter as message device, check "Start server" task and Run.
On client machine select "Client", "Miniport", select Test device - "RH adater", message adapter - Intel, then you'll see RH support aapter on server machine, select it as support device, select relevant test (VLAN) from the list below and run it. Logs are collected under Logs folder and shown in GUI.

Such a way we'll see whether this problem of the test engine or of communication of test suite with the test engine.
Comment 11 dawu 2012-08-24 01:09:46 EDT
Please refer to the attached of "logs.zip" for all logs under Logs folder.

Best Regards,
Dawn
Comment 12 dawu 2012-08-24 01:10:45 EDT
Created attachment 606753 [details]
logs
Comment 13 ybendito 2012-08-26 16:04:55 EDT
Attaching ZIP of empty folder "Logs" does not help.
Does this test pass or not?
Does it do something or not?
Log of dbgview also required - see the description in comment 10.
Comment 14 dawu 2012-08-26 22:48:49 EDT
(In reply to comment #13)
> Attaching ZIP of empty folder "Logs" does not help.
> Does this test pass or not?
Test case does not pass.

> Does it do something or not?
In client side, the ndistest.exe can start to run, but when it run job VlanSendRecv with initializing, the ndistest.exe quit immediately. the whole process only last less than one minute, and then do nothing again in client machine, noting abnormal thing happened in server side.
 
> Log of dbgview also required - see the description in comment 10.
Please refer to the attached "2K8-32-DebugView-withoutController.LOG" for details.

Best Regards,
Dawn
Comment 15 dawu 2012-08-26 22:49:53 EDT
Created attachment 607097 [details]
2K8-32-DebugView-withoutController.LOG
Comment 16 ybendito 2012-08-27 15:23:22 EDT
Please file this bug to WHCK 9200. It is very likely that this is incorrect behavior of the test script rather than problem of driver stack.
Comment 22 Mike Cao 2012-09-10 01:55:50 EDT
We got MSFT Manual Errata ID 793 to pass it , since it is a manual errata ,QE can not verify it until we do submission 

Feel Free to close this bug 

Mike
Comment 23 Yan Vugenfirer 2012-09-11 04:15:43 EDT
Closing - this is HCT bug and there is MS manual errata for this bug.
Comment 24 dawu 2013-02-25 02:59:39 EST
*** Bug 915182 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.