Bug 836489 - The process for the nntp://server protocol died unexpectedly.
The process for the nntp://server protocol died unexpectedly.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdepimlibs (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 04:59 EDT by Philipp Gampe
Modified: 2012-09-17 15:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 15:33:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp Gampe 2012-06-29 04:59:07 EDT
Description of problem:
Fetching new newsgroup posts results in the above message.

Version-Release number of selected component (if applicable):
Knode Version 4.8.4

How reproducible:


Steps to Reproduce:
1. open Knode
2. get new articles
  
Actual results:
error

Expected results:
new articles ;)

Additional info:
running knode from console reveals:
Gtk-Message: Failed to load module "pk-gtk-module"
knode(20040): ""lastExpire" - conversion of "-4713,1,1,0,0,0" to QDateTime failed"

$ grep -Rin "lastExpire" ~/.kde/share/apps/knode
./nntp.1/typo3.teams.edu.grpinfo:12:lastExpire=2011,5,4,0,0,0
./nntp.1/typo3.projects.seminars.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.gsoc.grpinfo:12:lastExpire=2011,3,21,0,0,0
./nntp.1/typo3.projects.user-registration.grpinfo:12:lastExpire=2011,1,24,0,0,0
./nntp.1/typo3.ug.nrw.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.translation.general.grpinfo:12:lastExpire=2011,5,4,0,0,0
./nntp.1/typo3.teams.workspace.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.timtab.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.documentation.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.ble.grpinfo:12:lastExpire=2011,8,2,0,0,0
./nntp.1/typo3.projects.typo3v4mvc.grpinfo:12:lastExpire=2011,5,4,0,0,0
./nntp.1/typo3.german.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.off-topic.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/flow3.teams.core.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.teams.core-v5.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.english.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.dev.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.teams.bugs.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/flow3.general.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.rte.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.calendar.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.showroom.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/info:18:lastExpire=2012,6,29,0,0,0
./nntp.1/typo3.install.general.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.performance.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.teams.dam.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.tt-news.grpinfo:12:lastExpire=2012,3,23,0,0,0
./nntp.1/typo3.projects.direct-mail.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.workflow.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.kickstarter.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.teams.core.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.community.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.piwik.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.teams.typo3org.grpinfo:12:lastExpire=2011,1,7,0,0,0
./nntp.1/typo3.install.debian.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.jobs.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.content-rendering.grpinfo:12:lastExpire=2011,5,12,0,0,0
./nntp.1/typo3.projects.dam.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.install.linux.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.realty.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.solr.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.projects.caretaker.grpinfo:12:lastExpire=2011,1,24,0,0,0
./nntp.1/typo3.translation.german.grpinfo:12:lastExpire=2010,12,28,0,0,0
./nntp.1/typo3.t3dd.grpinfo:12:lastExpire=2010,12,28,0,0,0

The server is lists.typo3.org which works all fine, because access with thunderbird works.
Comment 1 Philipp Gampe 2012-06-29 07:44:23 EDT
Ok, it looks like there is not network connection involved. I guess it can not create a socket.
At least nothing shows up in wireshark.
Comment 2 Philipp Gampe 2012-06-29 07:57:17 EDT
Another note, it works fine if I run knode with root permissions. So this seems to be some kind of permission problem when trying to create a socket.
Comment 3 Philipp Gampe 2012-06-29 18:40:57 EDT
OK, downgrading all related packages helps:

yum downgrade  kdepimlibs  kde-runtime-libs kde-baseapps-libs  kde-runtime kde-baseapps attica kwrite kde-runtime-flags  kate-part  kdesdk-kompare kdesdk-kompare-libs kdesdk-common  kdepimlibs-akonadi kdelibs attica konsole-part  kdelibs4  kdelibs-common kdelibs4 kdemultimedia-libs kdemultimedia-common konsolelibakonadi-filestore libakonadi-xml libkdepim-copy libkdepim-runtime-dms-copy libkmindexreader libmaildir kdepim-runtime-libs  kdepim-runtime  kdepim-runtime kdepim-runtime-libs kdepim kdepim-libs kdepim kdepim-libs

Note only downgrading kdepim kdepim-libs kdepim-runtime-libs kdepim-runtime does not work.
Comment 4 Rex Dieter 2012-06-29 20:43:35 EDT
kio_nntp is provided by kdepimlibs, so it's likely to be there (or lower) in the stack.
Comment 5 Philipp Gampe 2012-06-29 20:55:11 EDT
I will test tomorrow. Is this an upstream bug?

What would be the best way to track down the problem?
Comment 6 Philipp Gampe 2012-07-03 07:54:29 EDT
Ok, now I did the upgrade again.

After upgrade I got the error, but after a reboot the error was gone. Thus it works now :)
Comment 7 Rex Dieter 2012-09-17 15:33:43 EDT
Oh neat, seems we've banished the gremlin, i'll mark this closed (for now).  please do followup/reopen if  it happens again.

Note You need to log in before you can comment on or make changes to this bug.