Bug 836518 - [abrt] evolution-3.4.3-2.fc17: ews_sync_reply_cb: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.3-2.fc17: ews_sync_reply_cb: Process /usr/bin/evolution ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:2d83f5cd9ca4e878d7b24eadeac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 07:38 EDT by Mikhail
Modified: 2012-07-18 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 03:28:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 679241 None None None 2012-07-02 03:28:52 EDT

  None (edit)
Description Mikhail 2012-06-29 07:38:26 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
crash_function: ews_sync_reply_cb
executable:     /usr/bin/evolution
kernel:         3.4.4-3.fc17.i686.PAE
pid:            2116
pwd:            /home/mikhail
time:           Пт. 29 июня 2012 11:48:41
uid:            1000
username:       mikhail

backtrace:      Text file, 39095 bytes
build_ids:      Text file, 11521 bytes
dso_list:       Text file, 25142 bytes
gconf_subtree:  Text file, 11006 bytes
maps:           Text file, 83699 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mikhail/2

core_backtrace:
:d4b42e0f3c16488781fadc22101b06c4c2199fb3 0x8537 ews_sync_reply_cb libeews-1.2.so.0 -
:d4b42e0f3c16488781fadc22101b06c4c2199fb3 0xecc0 ews_response_cb libeews-1.2.so.0 -
:c56c7cbec97e922af0fd58d36305646744a58ee9 0x43fee - libsoup-2.4.so.1 -
:c56c7cbec97e922af0fd58d36305646744a58ee9 0x44281 - libsoup-2.4.so.1 -
:c56c7cbec97e922af0fd58d36305646744a58ee9 0x41b08 soup_session_cancel_message libsoup-2.4.so.1 -
:d4b42e0f3c16488781fadc22101b06c4c2199fb3 0xefb6 ews_cancel_request libeews-1.2.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0xebbf g_cclosure_marshal_VOID__VOIDv libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0xd042 - libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0x26486 g_signal_emit_valist libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0x26e64 g_signal_emit libgobject-2.0.so.0 -
:d0b2ee750bf29544a82c25b03f3fe22086c6c4be 0x29495 g_cancellable_cancel libgio-2.0.so.0 -
:97fa69562a37264199975f74ef0f0694c2195d15 0x459d2 mail_reader_message_selected_cb libevolution-mail.so -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0xf8da g_cclosure_marshal_VOID__STRING libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0xcd97 g_closure_invoke libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0x1ea3d - libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0x26ce1 g_signal_emit_valist libgobject-2.0.so.0 -
:15beedcb299b506c9c6a09bdfed67a02095644a5 0x26e64 g_signal_emit libgobject-2.0.so.0 -
:97fa69562a37264199975f74ef0f0694c2195d15 0x8da7d on_cursor_activated_idle libevolution-mail.so -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x44a31 - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x46feb g_main_context_dispatch libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x47390 - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x477f3 g_main_loop_run libglib-2.0.so.0 -
:ad9e27665744b5e0f27506032bcfd11acc11a16c 0x1859fd gtk_main libgtk-3.so.0 -
:df12a1e3d323853ce34c54ee5102ed22b29a1d9f 0x1cc3 main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=telecon17l.afbank.ru
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=928ad44a76a7008e0260558b00000016-1340871986.611444-913929144
:QTDIR=/usr/lib/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/mikhail/keyring-PAxHJ3
:QTINC=/usr/lib/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=mikhail
:USERNAME=mikhail
:MAIL=/var/spool/mail/mikhail
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mikhail/.local/bin:/home/mikhail/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mikhail
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1069
:LANG=en_US.UTF-8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/mikhail
:SHLVL=1
:LOGNAME=mikhail
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-dWHqrUE0TK,guid=715a4a2773591d9c1f8f9d4000000022
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mikhail
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-mikhail-ojqNT0/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1076,unix/unix:/tmp/.ICE-unix/1076
:GPG_AGENT_INFO=/run/user/mikhail/keyring-PAxHJ3/gpg:0:1
:SSH_AUTH_SOCK=/run/user/mikhail/keyring-PAxHJ3/ssh
:LC_TIME=ru_RU.utf8
:LC_NUMERIC=ru_RU.utf8
:LC_MONETARY=ru_RU.utf8
:LC_MEASUREMENT=ru_RU.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2116
:DESKTOP_STARTUP_ID=gnome-shell-1310-telecon17l.afbank.ru-evolution-2_TIME186882

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15711                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15711                15711                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/mikhail/.xsession-errors
:pos:	2902975
:flags:	02002
:2:/home/mikhail/.xsession-errors
:pos:	2902975
:flags:	02002
:3:socket:[111001]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[111005]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[109923]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[111075]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:socket:[8813630]
:pos:	0
:flags:	02004002
:12:socket:[111097]
:pos:	0
:flags:	02004002
:13:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:14:socket:[109979]
:pos:	0
:flags:	02004002
:15:/home/mikhail/.pki/nssdb/cert9.db
:pos:	2048
:flags:	02100002
:16:/var/tmp/etilqs_18ML2EkdG2Hgk87 (deleted)
:pos:	28
:flags:	02100002
:17:/var/tmp/etilqs_fb7QapnB4YnYfdy (deleted)
:pos:	2056
:flags:	02500002
:18:/var/tmp/etilqs_EVbsANIbc5rbnS9 (deleted)
:pos:	2048
:flags:	02500002
:19:/home/mikhail/.pki/nssdb/key4.db
:pos:	40
:flags:	02100002
:20:/var/tmp/etilqs_fo2xrogbEBDY8vG (deleted)
:pos:	28
:flags:	02100002
:21:/var/tmp/etilqs_GnKjeF9ooswwDLM (deleted)
:pos:	2056
:flags:	02500002
:22:/var/tmp/etilqs_zfNN9eqwIaYxO2V (deleted)
:pos:	2048
:flags:	02500002
:23:/etc/pki/nssdb/cert9.db
:pos:	2048
:flags:	02100000
:24:/var/tmp/etilqs_R6IfHygDEmv67Rn (deleted)
:pos:	28
:flags:	02100002
:25:/var/tmp/etilqs_59tNpZ8DL4UkVQT (deleted)
:pos:	2048
:flags:	02500002
:26:/etc/pki/nssdb/key4.db
:pos:	40
:flags:	02100000
:27:/var/tmp/etilqs_hMGUNHQilLBylIQ (deleted)
:pos:	28
:flags:	02100002
:28:/var/tmp/etilqs_qWgFIrDYHxG02Bl (deleted)
:pos:	2048
:flags:	02500002
:29:/home/mikhail/.local/share/evolution/mail/local/folders.db
:pos:	40
:flags:	02100002
:30:/home/mikhail/.local/share/evolution/mail/vfolder/folders.db
:pos:	40
:flags:	02100002
:31:/home/mikhail/.cache/evolution/mail/1333120619.4756.0@telecon17l.afbank.ru/folders.db
:pos:	8508416
:flags:	02100002
:32:anon_inode:inotify
:pos:	0
:flags:	02004000
:33:/home/mikhail/.cache/evolution/mail/1333516140.1463.1@telecon17l.afbank.ru/folders.db
:pos:	40
:flags:	02100002
:34:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:35:/dev/urandom
:pos:	0
:flags:	02000000
:36:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:37:socket:[116726]
:pos:	0
:flags:	02004002
:38:socket:[110581]
:pos:	0
:flags:	02000002
:39:/home/mikhail/.local/share/gvfs-metadata/home (deleted)
:pos:	0
:flags:	0100000
:40:/home/mikhail/.local/share/gvfs-metadata/home-ec14b158.log (deleted)
:pos:	0
:flags:	0100000
:41:socket:[1024262]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 24b82623-fdb0-487f-b726-0d6b01472500
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 4787.60
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2400
:System Memory: 1980
:System Swap: 16382
:Vendor: Unknown
:System:  
:Form factor: Unknown
:Kernel: 3.4.4-3.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10672:32902:20298) pci, None, HOST/PCI, 82Q35 Express DRAM Controller
:(32902:10673:32902:20298) pci, pcieport, PCI/PCI, 82Q35 Express PCI Express Root Port
:(4523:24833:4523:24833) pci, pata_marvell, STORAGE, 88SE6101/6102 single-port PATA133 interface
:(32902:10544:32902:20298) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10530:32902:20298) pci, ahci, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller
:(32902:10516:32902:20298) pci, None, PCI/ISA, 82801IO (ICH9DO) LPC Interface Controller
:(32902:4285:32902:1) pci, e1000e, ETHERNET, 82566DM-2 Gigabit Network Connection
:(32902:9294:32902:20298) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10549:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:32902:20298) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:32902:20298) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10564:32902:10564) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:32902:10566) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:32902:10560) pci, pcieport, PCI/PCI, Optiplex 755
:(32902:10562:32902:10562) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10676:32902:20298) pci, None, SIMPLE, 82Q35 Express MEI Controller
:(32902:10568:32902:10568) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:32902:18) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4098:43664:5963:43664) pci, snd_hda_intel, MULTIMEDIA, N/A
:(4098:26457:5963:57747) pci, radeon, VIDEO, NI Turks [AMD Radeon HD 6500]
:(4545:22545:4545:22545) pci, firewire_ohci, FIREWIRE, FW322/323
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 5112289 1992476 1941283 1286144 964570 964570
:/dev/sda5 /home ext4 4096 4096 27764613 2520937 1130550 6955008 6857251 6857251
:

var_log_messages:
:Jun 27 09:31:48 telecon17l abrt[12954]: File '/usr/bin/evolution' seems to be deleted
:Jun 27 09:31:53 telecon17l abrt[12954]: Saved core dump of pid 1570 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-27-09:31:48-1570 (128512000 bytes)
:Jun 27 10:14:51 telecon17l yum[13747]: Updated: evolution-mapi-debuginfo-3.4.3-2.fc17.i686
:Jun 27 10:15:38 telecon17l yum[13747]: Updated: evolution-mapi-3.4.3-2.fc17.i686
:Jun 28 11:41:12 telecon17l yum[1495]: Updated: evolution-debuginfo-3.4.3-2.fc17.i686
:Jun 28 12:54:39 telecon17l abrt[4724]: Saved core dump of pid 1063 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-28-12:54:37-1063 (121044992 bytes)
:Jun 28 14:15:24 telecon17l yum[7896]: Updated: evolution-3.4.3-2.fc17.i686
:Jun 28 14:15:25 telecon17l yum[7896]: Updated: evolution-NetworkManager-3.4.3-2.fc17.i686
:Jun 29 11:48:41 telecon17l kernel: [76968.155931] evolution[2116]: segfault at 0 ip ae8ca537 sp bfb7e860 error 6 in libeews-1.2.so.0.0.0[ae8c2000+28000]
:Jun 29 11:48:41 telecon17l abrt[4335]: File '/usr/bin/evolution' seems to be deleted
:Jun 29 11:48:47 telecon17l abrt[4335]: Saved core dump of pid 2116 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-29-11:48:41-2116 (129843200 bytes)

xsession_errors:
:(gnome-shell:1310): eds-WARNING **: edsf-persona-store.vala:2078: Error in address book view query: GDBus.Error:org.gnome.evolution.dataserver.AddressBook.AuthenticationRequired: Authentication Required
:(gnome-shell:1310): eds-WARNING **: edsf-persona-store.vala:2078: Error in address book view query: GDBus.Error:org.gnome.evolution.dataserver.AddressBook.AuthenticationRequired: Authentication Required
:(evolution:2116): e-data-server-ui-WARNING **: ENameSelector: Could not load "Global Address list": Authentication Required
:(evolution:2116): e-data-server-ui-WARNING **: ENameSelector: Could not load "Global Address list": Authentication Required
:(evolution-alarm-notify:1324): evolution-alarm-notify-WARNING **: alarm.c:254: Requested removal of nonexistent alarm!
:** (evolution:2116): WARNING **: Timeout was reached
:** (evolution:2116): WARNING **: Timeout was reached
:** (evolution:2116): WARNING **: Timeout was reached
:** (evolution:2116): WARNING **: Timeout was reached
:** (evolution:2116): WARNING **: Timeout was reached
:(evolution:2116): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
:(evolution:2116): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'
:(evolution:2116): GLib-GObject-CRITICAL **: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
:(evolution:2116): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'
:(evolution:2116): GLib-GObject-CRITICAL **: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
:(evolution:2116): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(evolution:2116): libsoup-CRITICAL **: soup_message_queue_remove: assertion `!item->removed' failed
:(evolution:2116): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GAsyncResult'
:(evolution:2116): GLib-GIO-CRITICAL **: g_async_result_get_user_data: assertion `G_IS_ASYNC_RESULT (res)' failed
:(evolution:2116): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
:** (evolution:4349): WARNING **: Timeout was reached
:(evolution:4349): camel-ews-provider-WARNING **: Unable to fetch the folder hierarchy: No response: Cannot connect to destination (cherry2.afbank.ru) :288 
:** (evolution:4349): WARNING **: Timeout was reached
:(evolution:4349): camel-ews-provider-WARNING **: Unable to fetch the folder hierarchy: No response: Cannot connect to destination (cherry2.afbank.ru) :288 
:** (evolution:4349): WARNING **: Timeout was reached
:** (evolution:4349): WARNING **: Timeout was reached
:(evolution:4349): camel-ews-provider-WARNING **: Unable to fetch the folder hierarchy: No response: Cannot connect to destination (cherry2.afbank.ru) :288 
:(evolution:4349): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GObject'
:(evolution:4349): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(evolution:4349): GLib-GObject-WARNING **: invalid uninstantiatable type `<invalid>' in cast to `GObject'
:(evolution:4349): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
:(evolution:4349): camel-ews-provider-WARNING **: Unable to fetch the folder hierarchy: No response: Cannot connect to destination (cherry2.afbank.ru) :288 
:(evolution:4349): camel-ews-provider-WARNING **: Unable to fetch the folder hierarchy: No response: Cannot connect to destination (cherry2.afbank.ru) :288
Comment 1 Milan Crha 2012-07-02 03:28:51 EDT
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

The report is missing backtrace, unfortunately. If you can find it in abrt cache and attach it, then I'll update the upstream bug with detailed backtrace.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=679241
Comment 2 Mikhail 2012-07-17 03:51:45 EDT
Please, explain me how find backtrace in abrt cache?
Comment 3 Milan Crha 2012-07-18 05:04:15 EDT
It's a bug in ABRT, I would not care of it. Once it happens again you can file a new bug report, and that time the ABRT will hopefully succeed. I do not know ABRT that well, but I guess it generates backtraces on demand, and saves them into file named 'backtrace' in its cache directory. According to the top of the comment #0, it generated 'backtrace' file with almost 40KB of text.
> backtrace:      Text file, 39095 bytes

Note You need to log in before you can comment on or make changes to this bug.