Bug 836559 - Apper fails to install rpm when clicking on a link in firefox
Apper fails to install rpm when clicking on a link in firefox
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
17
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 09:47 EDT by info@kobaltwit.be
Modified: 2012-09-26 05:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 18:45:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description info@kobaltwit.be 2012-06-29 09:47:53 EDT
Description of problem:
I tried to install the rpmfusion repositories by browsing to http://rpmfusion.org/Configuration
and clicking on the relevant links to install the packages directly via packagekit. Since I'm using kde as default workspace, the tool proposed to open the file is "apper". When I click ok to install the file, it pops up an error message:
could not resolve: file:///tmp/rpmfusion-nonfree-release-stable.noarch.rpm

I have checked, the rpm referred to is really in /tmp. So for some reason apper can't decode the "file" uri.

Version-Release number of selected component (if applicable):
apper-0.7.2-1.fc17.i686

How reproducible:
Always

Steps to Reproduce:
1. Start with a clean Fedora installation, install default kde workspace.
2. Start Firefox and browse to http://rpmfusion.org/Configuration
3. Click on one of the installation links
4. Be sure that apper is chosen to install this file
5. When apper asks if you want to install the file, click ok
  
Actual results:
Apper shows an error message: "Failed to install file"
"The query is not valid."
"Could not resolve: file:///tmp/rpmfusion-nonfree-release-stable.noarch.rpm"

The file referred to is available in /tmp though.

Expected results:
Normal successful installation.

Additional info:
This is a regression from Apper 0.7.1 on Fedora 16. See bug 781726. It was fixed and now it's broken again on the new version.

I'm using firefox. For reference, these are the links I tried to download, and for which firefox proposed to open them with apper:
http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
Comment 1 Rex Dieter 2012-06-29 10:05:08 EDT
odd, I cannot reproduce this error, it seems to download, and open and install in apper fine for me.

on both f16/x86_64, kde-4.8.3, apper-0.7.2-1, firefox-13.0.1-1

and f17/x86_64, kde-4.8.95, apper-0.7.2-2, firefox-13.0.1-1
Comment 2 Rex Dieter 2012-06-29 10:05:54 EDT
err, sorry, my f16 box had kde-4.8.4
Comment 3 info@kobaltwit.be 2012-06-29 12:31:35 EDT
I seem to have different application versions than you have:
kdelibs-common-4.8.4-5.fc17.i686
apper-0.7.2-1.fc17.i686

I have tried with both an account that has administrator rights and one that doesn't. It makes no difference, the operation fails.

Is there some log information I can provide you with ?
Comment 4 Rex Dieter 2012-09-07 14:39:21 EDT
ah, someone on irc  poked me about this, and  I think I see the problem  now.  apper fails to run scriptlets to register mimetypes.

to test, run as root:

update-desktop-database



and see if the problem persists or not.
Comment 5 Fedora Update System 2012-09-07 15:27:17 EDT
apper-0.7.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/apper-0.7.2-4.fc17
Comment 6 Rex Dieter 2012-09-07 16:45:30 EDT
These test builds implement the scriptlet addition I mentioned, fwiw.
Comment 7 Kevin Kofler 2012-09-07 17:15:12 EDT
Why didn't you file the F16 update and the F18 freeze override?
Comment 8 Rex Dieter 2012-09-08 08:31:12 EDT
ran out of time yesterday, will do today.
Comment 9 Fedora Update System 2012-09-08 08:33:15 EDT
apper-0.8.0-0.6.20120724git.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/apper-0.8.0-0.6.20120724git.fc18
Comment 10 Fedora Update System 2012-09-08 08:34:06 EDT
apper-0.7.2-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/apper-0.7.2-4.fc16
Comment 11 Fedora Update System 2012-09-08 15:23:56 EDT
Package apper-0.8.0-0.6.20120724git.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apper-0.8.0-0.6.20120724git.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13587/apper-0.8.0-0.6.20120724git.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-09-17 18:45:01 EDT
apper-0.8.0-0.6.20120724git.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-09-26 04:48:13 EDT
apper-0.7.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-09-26 05:05:16 EDT
apper-0.7.2-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.