This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 836595 - Remove users "lightdm" and "root" from userlist
Remove users "lightdm" and "root" from userlist
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: accountsservice (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 11:27 EDT by Heiko Adams
Modified: 2012-07-02 18:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 18:29:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my lightdm config (4.14 KB, text/plain)
2012-06-29 11:52 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2012-06-29 11:27:56 EDT
Description of problem:
LightDM offers the users "lightdm" and "root" for login in its userlist. But these users shouldn't be there because it should be impossible to login as these users.

Version-Release number of selected component (if applicable):
lightdm-1.3.1-1.fc17.x86_64
lightdm-gobject-1.3.1-1.fc17.x86_64
lightdm-gtk-1.1.6-3.fc17.x86_64

How reproducible:
allways

Steps to Reproduce:
1. make shure lightdm is your displaymanager
2. reboot the system
3.
  
Actual results:
LightDM's userlist has entrys for "lightdm" and "root"

Expected results:
LightDM's userlist should only list "normal" users which can login

Additional info:
Comment 1 Rex Dieter 2012-06-29 11:38:24 EDT
As far as I can tell, that's a bug elsewhere (accountservice?), lightdm.conf already contains:
...
[UserAccounts]
minimum-uid=1000
Comment 2 Rex Dieter 2012-06-29 11:39:16 EDT
though I suppose adding those 2 to the explicit blacklist:
hidden-users=...
couldn't hurt
Comment 3 Christoph Wickert 2012-06-29 11:43:35 EDT
Last time I tested, munimum-uid was already enough. I guess Heiko is using an oudated config.

Heiko, can you make sure your config is up to date?
Comment 4 Heiko Adams 2012-06-29 11:51:35 EDT
I didn't change anything on my config so it should be up2date
Comment 5 Heiko Adams 2012-06-29 11:52:01 EDT
Created attachment 595333 [details]
my lightdm config
Comment 6 Rex Dieter 2012-06-29 11:56:20 EDT
Oh sorry, the file I meant was
/etc/lightdm/users.conf

which has a comment about how accountsservice is used instead,

# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
Comment 7 Gregor Tätzner 2012-06-29 12:01:41 EDT
 users.conf is ignored by lightdm if accountsservice is running. For some time now user filtering is based on login shell*

@Heiko is nologin on lightdm user set in /etc/passwd?

*https://bugs.freedesktop.org/show_bug.cgi?id=44408
Comment 8 Rex Dieter 2012-06-29 12:06:01 EDT
In particular, what does this say?


$ dbus-send --system --print-reply \
  --dest=org.freedesktop.Accounts /org/freedesktop/Accounts \
  org.freedesktop.Accounts.ListCachedUsers

for me, I get :
method return sender=:1.12 -> dest=:1.129 reply_serial=2
   array [
      object path "/org/freedesktop/Accounts/User1001"
      object path "/org/freedesktop/Accounts/User1000"
   ]


$ rpm -q accountsservice
accountsservice-0.6.21-1.fc17.x86_64
Comment 9 Heiko Adams 2012-06-29 12:09:05 EDT
$ cat /etc/passwd|grep lightdm
lightdm:x:43:43::/var/log/lightdm:/sbin/nologin

$ cat /etc/passwd|grep root
root:x:0:0:root:/root:/bin/bash
operator:x:11:0:operator:/root:/sbin/nologin

$ rpm -q accountsservice
accountsservice-0.6.18-1.fc17.x86_64
Comment 10 Gregor Tätzner 2012-06-29 12:16:37 EDT
(In reply to comment #9)
> $ rpm -q accountsservice
> accountsservice-0.6.18-1.fc17.x86_64

What happens when you upgrade to accountsservice from updates-testing?
Comment 11 Heiko Adams 2012-06-29 12:29:15 EDT
Updating to accountsservice from updates-testing solves the problem
Comment 12 Rex Dieter 2012-06-29 12:36:16 EDT
OK, I'm conviced this is an accountsservice bug now, but looks like
https://admin.fedoraproject.org/updates/FEDORA-2012-9407/accountsservice-0.6.21-1.fc17
got pulled

and we have a new one pending:
https://admin.fedoraproject.org/updates/accountsservice-0.6.21-2.fc17

either fixes our particular problem here (for me, at least).
Comment 13 Gregor Tätzner 2012-07-02 02:46:53 EDT
https://admin.fedoraproject.org/updates/accountsservice-0.6.21-2.fc17

Can you push this update also to f16? lightdm in f16 should be affected by this issue, too
Comment 14 Fedora Update System 2012-07-02 09:28:00 EDT
accountsservice-0.6.21-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-10120/accountsservice-0.6.21-2.fc17
Comment 15 Rex Dieter 2012-07-02 09:34:22 EDT
Re: comment #13

Testing on f16, I don't experience this bug with
accountsservice-0.5.15-3.fc16
do you?
Comment 16 Gregor Tätzner 2012-07-02 11:49:07 EDT
uhm...no. I don't have a f16 system here. But probably you are right and the old accountsservice version is not affected by this issue.
Comment 17 Fedora Update System 2012-07-02 18:29:09 EDT
accountsservice-0.6.21-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.