Bug 836607 - mozilla-adblockplus-2.2.1 is available
mozilla-adblockplus-2.2.1 is available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla-adblockplus (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 11:52 EDT by Upstream Release Monitoring
Modified: 2012-12-09 16:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 22:29:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-06-29 11:52:30 EDT
Latest upstream release: 2.1
Current version in Fedora Rawhide: 2.0.3
URL: http://hg.adblockplus.org/downloads/raw-file/tip/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2012-07-04 05:02:30 EDT
Latest upstream release: 2.1.1
Current version in Fedora Rawhide: 2.0.3
URL: http://hg.adblockplus.org/downloads/raw-file/tip/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Andre Robatino 2012-07-09 01:30:24 EDT
The version at https://admin.fedoraproject.org/updates/FEDORA-2012-10405/mozilla-adblockplus-2.1.1-1.fc17 shows "Allow some non-intrusive advertising" is enabled by default in Filter Preferences (same as upstream). I thought your policy was to be different from upstream and have it disabled by default. Has that changed? (Personally I would prefer that it stay close to upstream, as long as the option still exists to turn the advertising off.)
Comment 3 Russell Golden 2012-07-09 12:42:49 EDT
It is ixs's policy, but so far, the only way we've found to disable the feature at compile-time is to patch out the exceptions list that is used for that feature.

The checkbox removes the exceptions list from the filters list when it is unchecked, and re-adds it when it is re-checked. I haven't been able to find where the crap that preference is stored, because it's not in about:config, and the "subscriptions_exceptionscheckbox" preference determines whether the checkbox is shown at all, not whether it is on or off.

The value of the checkbox has to be stored *somewhere* because its value persists between sessions, but for the life of me, I can't find it. It doesn't help that I don't know javascript, and even though I know some other programming languages, javascript's complete lack of structure and typing makes it all utter nonsense to me.

I don't like the current method of patching out the list, but it seems to be the only way.

If anyone at all can find where the value of the checkbox is stored so it can be disabled at compile-time while still leaving the list behind for users to enable, PLEASE post it on the bugzilla, in #fedora-devel, or email me.
Comment 4 Upstream Release Monitoring 2012-07-19 17:29:50 EDT
Latest upstream release: 2.1.2
Current version in Fedora Rawhide: 2.1.1
URL: http://hg.adblockplus.org/downloads/raw-file/tip/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 5 Upstream Release Monitoring 2012-11-23 03:29:13 EST
Latest upstream release: 2.2.1
Current version in Fedora Rawhide: 2.1.2
URL: http://hg.adblockplus.org/downloads/raw-file/tip/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 6 Fedora Update System 2012-11-23 14:48:24 EST
mozilla-adblockplus-2.2.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mozilla-adblockplus-2.2.1-1.fc17
Comment 7 Fedora Update System 2012-11-23 14:48:39 EST
mozilla-adblockplus-2.2.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mozilla-adblockplus-2.2.1-1.el6
Comment 8 Fedora Update System 2012-11-23 14:48:53 EST
mozilla-adblockplus-2.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mozilla-adblockplus-2.2.1-1.fc18
Comment 9 Fedora Update System 2012-11-23 22:29:57 EST
mozilla-adblockplus-2.2.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-12-01 04:51:22 EST
mozilla-adblockplus-2.2.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-12-09 16:05:14 EST
mozilla-adblockplus-2.2.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.