Bug 836637 - [BUG] skipx doesn't work as expected in the kickstarts
[BUG] skipx doesn't work as expected in the kickstarts
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: HOTFIX
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 13:35 EDT by Bill Peck
Modified: 2012-07-03 21:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 21:01:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-06-29 13:35:52 EDT
Description of problem:
having skipx defined in ks_meta doesn't actually do anything in the templates since it still evaluates to False.

What we probably want is {% if skipx is defined %}

Version-Release number of selected component (if applicable):
0.9.0-4

There could be other variables that have this issue as well.
Comment 1 Bill Peck 2012-06-29 15:42:20 EDT
http://gerrit.beaker-project.org/#/c/1171/
Comment 2 Dan Callaghan 2012-06-30 23:47:51 EDT
Thanks for catching and fixing this Bill. Looks like I made a transcription error with skipx and manual when I ported the kickstarts. And I never added a test for those either, it seems :-(
Comment 3 Dan Callaghan 2012-07-01 23:04:38 EDT
Beaker 0.9.0-7 is awaiting release.
Comment 4 Dan Callaghan 2012-07-03 21:01:32 EDT
Beaker 0.9.0-7 has been released as a hotfix.

Note You need to log in before you can comment on or make changes to this bug.