Bug 836653 - raid1 mirror reduction finishes "successfully" even though it failed to reduce the legs
Summary: raid1 mirror reduction finishes "successfully" even though it failed to reduc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Alasdair Kergon
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 840699
TreeView+ depends on / blocked
 
Reported: 2012-06-29 20:04 UTC by Corey Marthaler
Modified: 2013-02-21 08:11 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.97-2.el6
Doc Type: Bug Fix
Doc Text:
A failure to reduce the size of a Logical Volume was sometimes not detected and 'lvremove' exited successfully even though it had failed. Errors are now detected and reported.
Clone Of:
Environment:
Last Closed: 2013-02-21 08:11:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0501 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-02-20 21:30:45 UTC

Description Corey Marthaler 2012-06-29 20:04:53 UTC
Description of problem:
[root@hayes-01 bin]# lvs -a -o +devices
  LV                 Attr     LSize  Copy%  Devices
  reduce             Rwi-a-m- 52.00m 100.00 reduce_rimage_0(0),reduce_rimage_1(0)
  [reduce_rimage_0]  iwi-aor- 52.00m        /dev/etherd/e1.1p9(1)
  [reduce_rimage_1]  iwi-aor- 52.00m        /dev/etherd/e1.1p8(1)
  [reduce_rmeta_0]   ewi-aor-  4.00m        /dev/etherd/e1.1p9(0)
  [reduce_rmeta_1]   ewi-aor-  4.00m        /dev/etherd/e1.1p8(0)

[root@hayes-01 bin]# lvreduce -f -L 30M /dev/raid_sanity/reduce
  Rounding size to boundary between physical extents: 32.00 MiB
  WARNING: Reducing active logical volume to 32.00 MiB
  THIS MAY DESTROY YOUR DATA (filesystem etc.)
  Reducing logical volume reduce to 32.00 MiB
  Unable to reduce RAID LV - operation not implemented.
  Unable to reduce RAID LV - operation not implemented.
  Logical volume reduce successfully resized

[root@hayes-01 bin]# echo $?
0

# Note how the LV is now 32M, but none of the legs are!
[root@hayes-01 bin]# lvs -a -o +devices
  LV                 Attr     LSize  Copy%  Devices
  reduce             Rwi-a-m- 32.00m 100.00 reduce_rimage_0(0),reduce_rimage_1(0)
  [reduce_rimage_0]  iwi-aor- 52.00m        /dev/etherd/e1.1p9(1)
  [reduce_rimage_1]  iwi-aor- 52.00m        /dev/etherd/e1.1p8(1)
  [reduce_rmeta_0]   ewi-aor-  4.00m        /dev/etherd/e1.1p9(0)
  [reduce_rmeta_1]   ewi-aor-  4.00m        /dev/etherd/e1.1p8(0)


Version-Release number of selected component (if applicable):
2.6.32-278.el6.x86_64
lvm2-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-libs-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-cluster-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
cmirror-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012


How reproducible:
Everytime

Comment 1 Corey Marthaler 2012-06-29 20:05:19 UTC
This should be considered for 6.3.z.

Comment 3 Peter Rajnoha 2012-08-13 12:52:36 UTC
This is fixed in v2.02.97 (http://git.fedorahosted.org/cgit/lvm2.git/commit/?id=a5ddb347e569a953d6732d8d9f72857a560b5bcd):

# lvcreate -L 128m -m1 --type raid1 vg
  Logical volume "lvol0" created

# lvreduce -f -L 30M /dev/vg/lvol0
  Rounding size to boundary between physical extents: 32.00 MiB
  WARNING: Reducing active logical volume to 32.00 MiB
  THIS MAY DESTROY YOUR DATA (filesystem etc.)
  Reducing logical volume lvol0 to 32.00 MiB
  Unable to reduce RAID LV - operation not implemented.

# echo $?
5

# lvs
  LV    VG   Attr     LSize   Pool Origin Data%  Move Log Copy%  Convert
  lvol0 vg   rwi-a-m- 128.00m                             100.00

Comment 5 Nenad Peric 2012-10-30 09:10:15 UTC
Verified with :

lvm2-2.02.98-2.el6.x86_64

Comment 6 errata-xmlrpc 2013-02-21 08:11:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html


Note You need to log in before you can comment on or make changes to this bug.