Bug 836692 - SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'execmod' accesses on the file /usr/lib64/libzvbi.so.0.13.1.
SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'ex...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3fc61f83087a0b7fe2926e687b0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 20:31 EDT by Zoltan Hoppar
Modified: 2012-10-11 05:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-01 07:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltan Hoppar 2012-06-29 20:31:06 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.3-1.fc17.x86_64
time:           2012. jún. 30., szombat, 02.30.39 CEST

description:
:SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from 'execmod' accesses on the file /usr/lib64/libzvbi.so.0.13.1.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/usr/lib64/libzvbi.so.0.13.1 default label should be textrel_shlib_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /usr/lib64/libzvbi.so.0.13.1
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that gst-plugin-scanner should be allowed execmod access on the libzvbi.so.0.13.1 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:lib_t:s0
:Target Objects                /usr/lib64/libzvbi.so.0.13.1 [ file ]
:Source                        gst-plugin-scan
:Source Path                   /usr/libexec/gstreamer-0.10/gst-plugin-scanner
:Port                          <Ismeretlen>
:Host                          (removed)
:Source RPM Packages           gstreamer-0.10.36-1.fc17.x86_64
:Target RPM Packages           zvbi-0.2.33-12.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-132.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.3-1.fc17.x86_64 #1
:                              SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012. jún. 30., szombat, 02.29.36 CEST
:Last Seen                     2012. jún. 30., szombat, 02.29.36 CEST
:Local ID                      22da95de-ba06-46e5-afab-2fec22bc5212
:
:Raw Audit Messages
:type=AVC msg=audit(1341016176.152:133): avc:  denied  { execmod } for  pid=3176 comm="gst-plugin-scan" path="/usr/lib64/libzvbi.so.0.13.1" dev="dm-1" ino=798695 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1341016176.152:133): arch=x86_64 syscall=mprotect success=no exit=EACCES a0=7fbbbff6d000 a1=70000 a2=5 a3=0 items=0 ppid=3171 pid=3176 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=gst-plugin-scan exe=/usr/libexec/gstreamer-0.10/gst-plugin-scanner subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gst-plugin-scan,mozilla_plugin_t,lib_t,file,execmod
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-01 07:24:24 EDT
Do:

# /sbin/restorecon -v /usr/lib64/libzvbi.so.0.13.1
Comment 2 Yann Droneaud 2012-10-02 11:50:06 EDT
From a user point of view, having to run the command is not so great.

From my point of view, before asking me to enable a plugin to run code, you should explain why it is needed. And if needed why it wasn't already enabled ? is it a bug in the security policy, a bug in the zvbi package ?.
Comment 3 Daniel Walsh 2012-10-09 14:17:33 EDT
This is happening because /usr/lib64/libzvbi.so.0.13.1 was built without the PIC flag, I guess we can reopen this bug with them, but I am not sure how the file installed with the incorrect label.
Comment 4 Yann Droneaud 2012-10-11 05:37:04 EDT
Thanks for the clarification. I've also found explanations in bug #831595

Does a bug against libzvbi might be opened to ask for a rebuilt with PIC flag instead of using a modified SELinux policy ?

Note You need to log in before you can comment on or make changes to this bug.