Bug 836727 - Improve docs wrt new-sources vs upload
Improve docs wrt new-sources vs upload
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedpkg (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-30 12:01 EDT by Ville Skyttä
Modified: 2013-01-10 01:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 16:01:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2012-06-30 12:01:21 EDT
Man fedpkg, ditto in fedpkg --help:

       fedpkg new-sources [-h] files [files ...]
              Upload new source files

       fedpkg upload [-h] files [files ...]
              Upload source files

For someone who isn't intimately familiar with Fedora package maintenance process, this documentation wrt new-sources vs upload is insufficient and confusing.

"new-sources" behavior of removing existing files from .gitignore and sources (IIRC, it's been a while since I used it) should be documented, and "upload" also uploads new source files, it just appends to the list of existing ones.
Comment 1 Jesse Keating 2012-07-02 16:01:04 EDT
It is documented in the specific help output for each sub command (fedpkg new-sources --help / fedpkg upload --help) as well as the fedpkg man page.

Note You need to log in before you can comment on or make changes to this bug.