Bug 836736 - qpid-cpp is ftbfs on ARM
qpid-cpp is ftbfs on ARM
Status: CLOSED DUPLICATE of bug 820282
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-06-30 13:46 EDT by Peter Robinson
Modified: 2015-06-21 20:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 15:42:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-06-30 13:46:40 EDT
qpid-cpp-0.16-3.fc18

It looks like it's due to alignment errors

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=937055
Comment 1 Darryl L. Pierce 2012-07-03 11:29:28 EDT
The actual error is:

qpid/sys/rdma/RdmaClient.cpp: In function 'void qpid::tests::write(Rdma::AsynchIO&)':
qpid/sys/rdma/RdmaClient.cpp:100:62: error: cast from 'char*' to 'uint32_t* {aka unsigned int*}' increases required alignment of target type [-Werror=cast-align]
qpid/sys/rdma/RdmaClient.cpp: In function 'void qpid::tests::data(qpid::sys::Poller::shared_ptr, Rdma::AsynchIO&, Rdma::Buffer*)':
qpid/sys/rdma/RdmaClient.cpp:119:58: error: cast from 'char*' to 'uint32_t* {aka unsigned int*}' increases required alignment of target type [-Werror=cast-align]

Though there seem to be errors regarding ARM GCC that should be addressed as well by that package.
Comment 2 Jon Ciesla 2012-09-20 12:00:56 EDT
I get:

/bin/sh ../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../include -I../include -I. -I=.   -Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual -Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch -Wno-system-headers -Woverloaded-virtual -DQPID_LIBEXEC_DIR=\"/usr/libexec/qpid\" -DBOOST_FILESYSTEM_VERSION=3 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -march=armv5te -mfloat-abi=soft -DNDEBUG -O3 -Wno-unused-result -c -o qpid/sys/posix/SystemInfo.lo qpid/sys/posix/SystemInfo.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../include -I../include -I. -I=. -Werror -pedantic -Wall -Wextra -Wno-shadow -Wpointer-arith -Wcast-qual -Wcast-align -Wno-long-long -Wvolatile-register-var -Winvalid-pch -Wno-system-headers -Woverloaded-virtual -DQPID_LIBEXEC_DIR=\"/usr/libexec/qpid\" -DBOOST_FILESYSTEM_VERSION=3 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv5te -mfloat-abi=soft -DNDEBUG -O3 -Wno-unused-result -c qpid/sys/posix/SystemInfo.cpp  -fPIC -DPIC -o qpid/sys/posix/.libs/SystemInfo.o
qpid/sys/posix/SystemInfo.cpp: In function 'void qpid::sys::SystemInfo::getLocalIpAddresses(uint16_t, std::vector<qpid::Address>&)':
qpid/sys/posix/SystemInfo.cpp:93:67: error: cast from 'sockaddr*' to 'sockaddr_in6*' increases required alignment of target type [-Werror=cast-align]
cc1plus: all warnings being treated as errors
Comment 3 Darryl L. Pierce 2012-10-12 15:42:27 EDT

*** This bug has been marked as a duplicate of bug 820282 ***

Note You need to log in before you can comment on or make changes to this bug.