Bug 836771 - SELinux is preventing /usr/sbin/abrt-dbus from 'create' accesses on the lnk_file .lock.
Summary: SELinux is preventing /usr/sbin/abrt-dbus from 'create' accesses on the lnk_f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:dc96f11892a9fe70770d8b64234...
: 836768 836770 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-01 06:17 UTC by marciobraz2010
Modified: 2013-02-26 02:37 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-12 01:15:31 UTC
Type: ---


Attachments (Terms of Use)

Description marciobraz2010 2012-07-01 06:17:58 UTC
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.3-1.fc17.x86_64
time:           Dom 01 Jul 2012 03:17:51 BRT

description:
:SELinux is preventing /usr/sbin/abrt-dbus from 'create' accesses on the lnk_file .lock.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If você acredita que o abrt-dbus deva ser permitido acesso de create em .lock lnk_file  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep abrt-dbus /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:user_home_t:s0
:Target Objects                .lock [ lnk_file ]
:Source                        abrt-dbus
:Source Path                   /usr/sbin/abrt-dbus
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           abrt-dbus-2.0.10-4.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-134.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.3-1.fc17.x86_64 #1
:                              SMP Mon Jun 18 19:53:17 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Dom 01 Jul 2012 03:09:52 BRT
:Last Seen                     Dom 01 Jul 2012 03:09:52 BRT
:Local ID                      f885386d-acc6-4ad5-b59f-aba9114a5cd3
:
:Raw Audit Messages
:type=AVC msg=audit(1341122992.683:132): avc:  denied  { create } for  pid=2397 comm="abrt-dbus" name=".lock" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_home_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1341122992.683:132): arch=x86_64 syscall=symlink success=yes exit=0 a0=7fff04409de0 a1=7fff04409d60 a2=35e8547322 a3=35f0410d4c items=0 ppid=1 pid=2397 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-dbus exe=/usr/sbin/abrt-dbus subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)
:
:Hash: abrt-dbus,abrt_t,user_home_t,lnk_file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:

Comment 1 Miroslav Grepl 2012-07-01 21:17:28 UTC
*** Bug 836770 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2012-07-01 21:17:58 UTC
*** Bug 836768 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2012-07-01 21:20:22 UTC
Why is abrt-dbus using homedir?

Comment 4 Daniel Walsh 2012-07-11 03:28:56 UTC
I would figure this is a mislabeled directory.

Comment 6 Fedora Update System 2012-12-20 08:54:35 UTC
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18

Comment 7 Fedora Update System 2012-12-20 09:45:01 UTC
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17

Comment 8 Fedora Update System 2012-12-21 01:28:50 UTC
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-01-12 01:15:33 UTC
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-02-26 02:37:37 UTC
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.