This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 836801 - impossibility to long-time log pulseaudio
impossibility to long-time log pulseaudio
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pulseaudio (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 10:32 EDT by Matěj Cepl
Modified: 2014-08-13 05:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-13 05:37:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example test case (~/.pulse/daemon.conf causing the problem) (68 bytes, text/plain)
2012-07-01 10:32 EDT, Matěj Cepl
no flags Details
the first example sound (26.09 KB, audio/x-wav)
2012-07-01 10:33 EDT, Matěj Cepl
no flags Details
second wave file (30.59 KB, audio/x-wav)
2012-07-01 10:36 EDT, Matěj Cepl
no flags Details
log from pulseaudio daemon when ~/.pulse/daemon.conf is not present (37.03 KB, text/plain)
2012-07-01 10:37 EDT, Matěj Cepl
no flags Details
piece of /var/log/messages when the sound system is broken (i.e., ~/.pulse/daemon.conf is present) (27.61 KB, text/plain)
2012-07-01 10:38 EDT, Matěj Cepl
no flags Details
piece of /var/log/messages when the sound system is broken (i.e., ~/.pulse/daemon.conf is present) (27.61 KB, text/plain)
2012-07-01 10:41 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2012-07-01 10:32:51 EDT
Created attachment 595531 [details]
example test case (~/.pulse/daemon.conf causing the problem)

Description of problem:
I am trying to reproduce https://bugzilla.mozilla.org/show_bug.cgi?id=762658 but the problem is that whenever I restart pulseaudio to get a log (following the HOWTO on https://wiki.ubuntu.com/PulseAudio/Log) I have to restart pulseaudio daemon and then the problem goes away. So, I am looking for a way how to log pulseaudio per default.

I tried to add the attached minimal configuration file as ~/.pulse/daemon.conf but then after playing one sound, the next one is horribly corrupted and whole sound gets then to state when any attempt to play anything else results in horrible beeping-scratching-useless crap sound.

Version-Release number of selected component (if applicable):
pulseaudio-1.1-9.el7.x86_64

How reproducible:
100% (5 out of 5 at least)

Steps to Reproduce:
1.put the attached conf file as ~/.pulse/daemon.conf
2.pkill -f pulseaudio
3.paplay thunderrumble.wav
4.paplay thunder-long.wav
  
Actual results:
First WAV file plays well, second (or any other attempt to use sound system) results in horribly corrupted sound.
It is not possible to log pulseaudio for a longer time (i.e., per default)

Expected results:
There is a way how to make pulseaudio to generate logfiles per default (even though they could be huge)

Additional info:
Comment 1 Matěj Cepl 2012-07-01 10:33:49 EDT
Created attachment 595532 [details]
the first example sound
Comment 2 Matěj Cepl 2012-07-01 10:36:35 EDT
Created attachment 595533 [details]
second wave file

Actually now when retesting the case again, it seems that I am sometimes able to achieve the same erroneous behavior just with playing thunderrumble.wav again and again, I just need more attempts to sound system fail. With playing these two sound files in sequence I get broken behavior 100%.
Comment 3 Matěj Cepl 2012-07-01 10:37:33 EDT
Created attachment 595534 [details]
log from pulseaudio daemon when ~/.pulse/daemon.conf is not present
Comment 4 Matěj Cepl 2012-07-01 10:38:22 EDT
Created attachment 595535 [details]
piece of /var/log/messages when the sound system is broken (i.e., ~/.pulse/daemon.conf is present)
Comment 5 Matěj Cepl 2012-07-01 10:41:13 EDT
Created attachment 595536 [details]
piece of /var/log/messages when the sound system is broken (i.e., ~/.pulse/daemon.conf is present)
Comment 10 Matěj Cepl 2014-08-13 05:37:51 EDT
No, it is not relevant, it got resolved somehow. At least with pulseaudio-3.0-22.el7.x86_64 I cannot reproduce it anymore.

Note You need to log in before you can comment on or make changes to this bug.