Bug 836817 - R-core depends on texlive-latex
R-core depends on texlive-latex
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 13:23 EDT by Matthew Saltzman
Modified: 2012-07-25 16:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 16:48:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2012-07-01 13:23:28 EDT
Description of problem:
R-core has a dependency on texlive-latex and texlive-dvips packages.  Jindrich Novy's texlive-2012 repo has just undergone a major update changing package names from texlive-* to tex-*, so R won't install when using texlive-2012.


Version-Release number of selected component (if applicable):
R-core-2.15.0-1.fc17.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Install texlive from http://jnovy.fedorapeople.org/texlive/2012/packages.fc17/
2. yum install R R-core
3.
  
Actual results:
R-core fails to install because of dependencies

Expected results:
R-core installs and works

Additional info:
Error messages

$ sudo yum install R R-core R-devel
Loaded plugins: changelog, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package R.x86_64 0:2.15.0-1.fc17 will be installed
---> Package R-core.x86_64 0:2.15.0-1.fc17 will be installed
--> Processing Dependency: texlive-latex for package: R-core-2.15.0-1.fc17.x86_64
Package texlive-latex-2007-70.fc17.x86_64 is obsoleted by 1:tex-latex-svn23639-1.noarch which is already installed
--> Processing Dependency: texlive-dvips for package: R-core-2.15.0-1.fc17.x86_64
Package texlive-dvips-2007-70.fc17.x86_64 is obsoleted by 1:tex-dvips-svn26765-1.noarch which is already installed
---> Package R-devel.x86_64 0:2.15.0-1.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: R-core-2.15.0-1.fc17.x86_64 (fedora)
           Requires: texlive-latex
           Available: texlive-latex-2007-70.fc17.x86_64 (fedora)
               texlive-latex = 2007-70.fc17
Error: Package: R-core-2.15.0-1.fc17.x86_64 (fedora)
           Requires: texlive-dvips
           Available: texlive-dvips-2007-70.fc17.x86_64 (fedora)
               texlive-dvips = 2007-70.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Jindrich Novy 2012-07-01 14:12:23 EDT
One should use virtual provides to TeX packages like tex(latex):

http://fedoraproject.org/wiki/Packaging_tricks

Then everything should be OK.
Comment 2 hannes 2012-07-01 14:23:31 EDT
The other possibility would be that the tex-latex packages provide texlive-latex, or?
Comment 3 Susi Lehtola 2012-07-02 02:38:45 EDT
Yes, but that would be a workaround. Since there are many LaTeX compilers around, packages that just need a compiler should require it in generic form as instructed in the packaging tricks.
Comment 4 Jindrich Novy 2012-07-02 05:02:35 EDT
R also uses broken dependencies for dvips (texlive-dvips) and mixes tetex-latex and texlive-latex obsolete dependencies in the spec. I fixed them in rawhide for now.
Comment 5 Joel 2012-07-02 13:02:01 EDT
Why only rawhide?
Comment 6 Tom "spot" Callaway 2012-07-02 13:03:42 EDT
I'm fixing everything else along with the 2.15.1 update right now.
Comment 7 Fedora Update System 2012-07-02 15:44:23 EDT
R-2.15.1-1.fc16,rpy-2.2.6-1.fc16,rkward-0.5.7-2.fc16.4 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/R-2.15.1-1.fc16,rpy-2.2.6-1.fc16,rkward-0.5.7-2.fc16.4
Comment 8 Fedora Update System 2012-07-02 15:45:24 EDT
R-2.15.1-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/R-2.15.1-1.el5
Comment 9 Fedora Update System 2012-07-02 15:45:35 EDT
R-2.15.1-1.fc17,rpy-2.2.6-1.fc17,rkward-0.5.7-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/R-2.15.1-1.fc17,rpy-2.2.6-1.fc17,rkward-0.5.7-6.fc17
Comment 10 Fedora Update System 2012-07-02 15:46:08 EDT
R-2.15.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/R-2.15.1-1.el6
Comment 11 Donnie Pennington 2012-07-02 16:56:47 EDT
Shouldn't R-core package be included in the update?
Comment 12 Tom "spot" Callaway 2012-07-02 17:08:57 EDT
R-core is a subpackage of R, it is included in the update. Fedora updates are described/defined by their "SRPM" names.
Comment 13 Fedora Update System 2012-07-03 11:51:26 EDT
Package R-2.15.1-1.fc16, rpy-2.2.6-1.fc16, rkward-0.5.7-2.fc16.4:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing R-2.15.1-1.fc16 rpy-2.2.6-1.fc16 rkward-0.5.7-2.fc16.4'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10206/R-2.15.1-1.fc16,rpy-2.2.6-1.fc16,rkward-0.5.7-2.fc16.4
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-07-10 16:48:13 EDT
R-2.15.1-1.fc16, rpy-2.2.6-1.fc16, rkward-0.5.7-2.fc16.4 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2012-07-10 17:01:31 EDT
R-2.15.1-1.fc17, rpy-2.2.6-1.fc17, rkward-0.5.7-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-07-25 16:01:53 EDT
R-2.15.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-07-25 16:02:08 EDT
R-2.15.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.