Bug 836822 - Bring SNI support to wget
Bring SNI support to wget
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
http://savannah.gnu.org/bugs/?26786
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 14:25 EDT by Tobias Mueller
Modified: 2012-11-10 12:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-10 12:38:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Mueller 2012-07-01 14:25:15 EDT
Description of problem:
wget doesn't support SNI just right now.

$ wget --version
GNU Wget 1.12 built on linux-gnu.

+digest +ipv6 +nls +ntlm +opie +md5/openssl +https -gnutls +openssl 
-iri 

Wgetrc: 
    /etc/wgetrc (system)
Locale: /usr/share/locale 
Compile: gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc" 
    -DLOCALEDIR="/usr/share/locale" -I. -I../lib -O2 -g -pipe -Wall 
    -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector 
    --param=ssp-buffer-size=4 -m64 -mtune=generic 
Link: gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions 
    -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic 
    -lssl -lcrypto -ldl -lz /usr/lib64/libssl.so 
    /usr/lib64/libcrypto.so -ldl -lrt ftp-opie.o openssl.o http-ntlm.o 
    gen-md5.o ../lib/libgnu.a 

Copyright © 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
<http://www.gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Nikšić <hniksic@xemacs.org>.
Currently maintained by Micah Cowan <micah@cowan.name>.
Please send bug reports and questions to <bug-wget@gnu.org>.
$

I would have expected it to support SNI.

There is a patch since 2009: http://www.mail-archive.com/bug-wget@gnu.org/msg00263.html and a bug: http://savannah.gnu.org/bugs/?26786 so if this patch could be backported, it'd be highly appreciated.

There is also an Ubuntu bug with test cases here: https://bugs.launchpad.net/ubuntu/+source/wget/+bug/338242

My testcase is:
$ wget -O- https://vote.gnome.org
--2012-07-01 20:24:59--  https://vote.gnome.org/
Resolving vote.gnome.org... 209.132.180.176
Connecting to vote.gnome.org|209.132.180.176|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2012-07-01 20:25:00 ERROR 403: Forbidden.
$
Comment 1 Tomáš Hozza 2012-10-09 06:07:33 EDT
This issue has been fixed in wget-1.12-5.fc16. You can wait for the next wget update or use packages from here http://koji.fedoraproject.org/koji/buildinfo?buildID=358963
Comment 2 Fedora Update System 2012-10-16 06:47:54 EDT
wget-1.13.4-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/wget-1.13.4-7.fc17
Comment 3 Fedora Update System 2012-10-16 06:49:32 EDT
wget-1.12-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wget-1.12-6.fc16
Comment 4 Fedora Update System 2012-10-16 20:20:28 EDT
Package wget-1.13.4-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wget-1.13.4-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16234/wget-1.13.4-7.fc17
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.