Bug 836823 - RFE: Rebuild Macaulay2 with gmp, not mpir, and with pari 2.3 or 2.5
RFE: Rebuild Macaulay2 with gmp, not mpir, and with pari 2.3 or 2.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Macaulay2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 821191
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 14:41 EDT by Paulo Andrade
Modified: 2012-07-23 15:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 15:11:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-07-01 14:41:11 EDT
The rebuild is required once pari 2.5 hits rawhide.

The patches were written by me several month ago, and are documented in the spec file.

Spec URL: http://fedorapeople.org/~pcpa/Macaulay2.spec
SRPM URL: http://fedorapeople.org/~pcpa/Macaulay2-1.4-6.fc18.src.rpm
Comment 1 Rex Dieter 2012-07-01 14:57:05 EDT
Why not mpir?
Comment 2 Rex Dieter 2012-07-01 14:57:54 EDT
.spec includes comment:

# link to gmp, not mpir to avoid possible issues with gmp'ed pari

though a little more detail would be nice. :)
Comment 3 Paulo Andrade 2012-07-01 17:14:28 EDT
I did choose to not package mpir in Mandriva, and so far gmp is doing good enough, but you may ignore the mpir patch in the RFE :-) Still, my sagemath package will not use mpir...
Comment 4 Rex Dieter 2012-07-23 15:11:17 EDT
* Sun Jul 1 2012 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 1.4-6
- Link to gmp not mpir.
- Rebuild with pari 2.5.

Note You need to log in before you can comment on or make changes to this bug.