Bug 83688 - No sound with CDs.
No sound with CDs.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-06 22:52 EST by Steve Brown
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 11:14:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Brown 2003-02-06 22:52:32 EST
Description of problem:

My sound card, "Intel 82801DB AC", was detected and plays the test sound fine. 
With the MPG123 plugin installed (obtained from http://xmms.org), I can play
.MP3 files on my hard drive.  When I try to play a CD on xmms (or kscd), it
looks like it's playing -- the elapsed time and track numbers appear on the
screen -- but no sound comes from my speakers.  Since I can play CDs in Windows
XP, I have to assume that my drive and sound card are installed correctly (on my
brand new Gateway 500S computer).  I checked volume control and mixer and all
seems to be OK.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Put in a CD.
2.  Run xmms.
3.  Add drive (in xmms) /mnt/cdrom.
    
Actual results:

Tracks are listed (by number, not title) and timer counts elapsed time.  No
sound -- and no visualization.


Expected results:

Music!


Additional info:
Comment 1 Bill Nottingham 2003-02-07 01:19:17 EST
Does gnome-cd, or other CD players work?
Comment 2 Warren Togami 2003-02-09 15:56:37 EST
Most likely your Windows XP is using "digital" playback instead of analog, and
your CD-ROM drive doesn't have the analog cable going to the sound card?

Either that, or did you go into the Mixer and turn up the volume on the CD channel?
Comment 3 Steve Brown 2003-02-15 21:54:06 EST
to: notting@redhat.com

In 'Phoebe', I cannot play CDs on any player I've tried (xmms, kscd, gnome-cd).


to: warren@togami.com

I will check with Gateway about the "analog cable" as a workaround, BUT...
shouldn't 'Phoebe' attempt to play the CD using digital playback???  Using
analog playback seems like a step backwards, doesn't it?
Comment 4 Warren Togami 2003-02-15 22:14:51 EST
Using analog playback is actually better for computers because it uses far less
CPU, also you can adjust its volume independently on its own channel in the
mixer.  If you use digital playback you can only adjust its volume on the "pcm"
channel which is also wave output.  Also you usually do not have higher sound
quality with digital playback.

I don't know if Linux can do digital CD playing, I never tried.  It is less
convenient than analog CD playing anyway.
Comment 5 Bill Nottingham 2003-02-15 22:31:27 EST
If it fails in all CD players, it's not an xmms bug, rather a
driver/HW/configuration issue.
Comment 6 Steve Brown 2003-02-24 21:49:18 EST
warren@togami.com:

Thanks for the information about analog playback.  I opened my new Gateway
machine and found that there was no 'analog audio connector'.  I informed
Gateway that this cable was missing and they promptly sent two of them to me, no
charge.  I installed it and now I can play CDs.

I'm not sure if this item is still considered a bug, but I hope this information
will be helpful to others.
Comment 7 Alan Cox 2003-06-05 10:46:10 EDT
Closing as NOTABUG. With XP assuming digital playback (at least for now but as some
copy corrupted CD's only work in analog mode it may change) we do need to ship a
digital CD player eventually

Note You need to log in before you can comment on or make changes to this bug.