This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 836896 - Installer replaces hybrid MBR with protective MBR, Windows no longer boots
Installer replaces hybrid MBR with protective MBR, Windows no longer boots
Status: CLOSED DUPLICATE of bug 744496
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 02:44 EDT by Dave Vasilevsky
Modified: 2013-01-10 01:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 21:48:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda log (16.54 KB, text/x-log)
2012-07-02 19:49 EDT, Dave Vasilevsky
no flags Details
Anaconda program log (113.48 KB, text/x-log)
2012-07-02 19:49 EDT, Dave Vasilevsky
no flags Details
Anaconda storage log (397.15 KB, text/x-log)
2012-07-02 19:50 EDT, Dave Vasilevsky
no flags Details

  None (edit)
Description Dave Vasilevsky 2012-07-02 02:44:07 EDT
Description of problem:

My MacBook4,1 triple-boots OS X, Windows and Linux. To get Windows to boot, a hybrid MBR is required. When I install F17 the hybrid MBR is replaced with a protective MBR, and Windows no longer boots.

This would be understandable if some of the partitions in the hybrid MBR were changed, since it would then be unclear what should be done with the MBR. However, in my case none of the hybridized partitions is affected, so the MBR should be left alone.


How reproducible: Always


Steps to Reproduce:
1. Setup a Mac with the following GPT partitions:

   i.   EFI system partition
   ii.  OS X HFS+
   iii. Shared FAT32
   iv.  Windows NTFS
   v.   Free space

The hybrid MBR contains entries:
   i.   EE - protective
   ii.  AF - OS X
   iii. 0c - Shared
   iv.  Windows

2. Boot from Fedora 17 Live Desktop USB in EFI mode, install to free space with default options

  
Actual results:

The resulting partition layout:
   i.   EFI system partition
   ii.  OS X HFS+
   iii. Shared FAT32
   iv.  Windows NTFS
   v.   Fedora EFI boot HFS+
   vi.  Fedora boot ext4
   vii. Fedora LVM

The MBR is protective, one giant EE partition. OS X and Fedora boot, but Windows does not.


Expected results:

The MBR should remain hybrid, referring to the same partitions as before. Windows should still boot.
Comment 1 Jesse Keating 2012-07-02 16:14:15 EDT
Can you please attach the log files found in /var/log/anaconda/ on the installed system (or if you're re-doing the install from /tmp/*log at the end of the install).  We'll want to see why the decision was made to touch the mbr at all.
Comment 2 Dave Vasilevsky 2012-07-02 19:49:36 EDT
Created attachment 595834 [details]
Anaconda log
Comment 3 Dave Vasilevsky 2012-07-02 19:49:55 EDT
Created attachment 595835 [details]
Anaconda program log
Comment 4 Dave Vasilevsky 2012-07-02 19:50:41 EDT
Created attachment 595836 [details]
Anaconda storage log
Comment 5 Dave Vasilevsky 2012-07-02 19:54:00 EDT
It looks like parted auto-"restores" a protective MBR whenever a GPT is edited, even if the MBR is hybrid and there's no good reason to change it. :(
Comment 6 Jesse Keating 2012-07-02 21:48:57 EDT
I'm closing this as a duplicate of bug 744496 (which in turn is listed as a duplicate of bug 746885 because 744496 has a more recognizable subject and details in the bug.

Bottom line, it's a known issue.

*** This bug has been marked as a duplicate of bug 744496 ***
Comment 7 Dave Vasilevsky 2012-07-02 21:55:55 EDT
Ok, thanks for taking a look.

Note You need to log in before you can comment on or make changes to this bug.