Bug 836918 - Unable to login into Xfce session
Unable to login into Xfce session
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 03:42 EDT by hannes
Modified: 2012-07-02 14:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 14:12:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lightdm.log from a failed login attempt to Xfce and a successful one to fluxbox (8.83 KB, text/x-log)
2012-07-02 13:19 EDT, hannes
no flags Details

  None (edit)
Description hannes 2012-07-02 03:42:39 EDT
Description of problem:
Since this morning I was not able to log in to my Xfce 4.10 session. I use the repo provided by Kevin. I tried to set selinux to permissive but this didn't help. I finally found the possibility to log in to a fluxbox session and I looked into the yum history to see some changes related to this.
I downgraded accountsservice to the stable version
rpm -qa accountsservice\*
accountsservice-0.6.18-1.fc17.x86_64
but it was still not possible to login. Previously the version of accountsservice was accountsservice-0.6.21-2.fc17.x86_64, which I installed yesterday from updates-testing.

Version-Release number of selected component (if applicable):
rpm -qa lightdm\*
lightdm-gtk-1.1.6-3.fc17.x86_64
lightdm-1.2.2-15.fc17.x86_64
lightdm-gobject-1.2.2-15.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Select Xfce Session in lightdm
2. Select user and enter password

Additional info:
I don't know which additional info would be relevant. I just could say that until this morning everything worked perfectly.
Comment 1 Rex Dieter 2012-07-02 13:14:02 EDT
When it fails, can you find anything interesting in any of
~/.xsession-errors
or
/var/log/lightdm/*.log 
?
Comment 2 hannes 2012-07-02 13:19:58 EDT
Created attachment 595784 [details]
lightdm.log from a failed login attempt to Xfce and a successful one to fluxbox
Comment 3 hannes 2012-07-02 13:21:37 EDT
I found something, first I logged into fluxbox and logged out again to try if Xfce will work. It didn't work and so I logged into fluxbox again.
Comment 4 Rex Dieter 2012-07-02 13:34:09 EDT
[+26.29s] DEBUG: Session 906 running command /etc/X11/xinit/Xsession startxfce4
[+26.37s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session1
[+26.65s] DEBUG: Session 906 exited with return value 0

So, during those 30 seconds, nothing happens?
Comment 5 hannes 2012-07-02 13:35:53 EDT
Well the screen went black and after a blinking cursor appeared in the upper left corner lightdm came up again.
Comment 6 Rex Dieter 2012-07-02 13:36:08 EDT
and for that given failed session, nothing in ~/.xsession-errors ?
Comment 7 hannes 2012-07-02 13:44:41 EDT
Ok, just tried and there is absolutely nothing in .xsession-errors after a failed login attempt. It's empty. I removed all .xsessions files before logging out and after trying to login I checked it from a virtual console and it was empty.
Comment 8 Rex Dieter 2012-07-02 14:07:10 EDT
I'm out of ideas, and can't reproduce this. :(
Comment 9 hannes 2012-07-02 14:12:18 EDT
Sorry, I now probably know the cause of this. I tried to undo changes I made to fix a bug with Qt and probably this was what caused the failure to start Xfce. 
I am really sorry for missing this one and thanks for your help and sorry for stealing your time.

Note You need to log in before you can comment on or make changes to this bug.