Bug 83694 - redhat-config-printer quite useless in a text mode
redhat-config-printer quite useless in a text mode
Product: Red Hat Linux
Classification: Retired
Component: newt (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2003-02-06 23:26 EST by Michal Jaegermann
Modified: 2015-01-07 19:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-09-10 14:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2003-02-06 23:26:14 EST
Description of problem:

An attempt to configure a printer in text mode on console does not
show anything which can be actually used.  What is on a screen is not
really readable, with a cursor position which can be only guessed and
selected buttons "jumping" around once "pressed".  It is possible to
type in a queue name and pick up a type but that seems to be about it.
At that point apparently the only possible actions (hard really tell
but few blind tries did not reveal anything else) is either "Next" or
"Cancel" and none of that results in anything resembling a printer

Readability is not a strong point of any of "tui" configuration
utilities but 'redhat-config-printer' seems here to be taking the

Comment 1 Tim Waugh 2003-02-07 04:04:13 EST
If you don't have newt-0.51.4-1 installed yet, please fetch it from rawhide.

If that doesn't correct the problem, please let me know what 'echo $LANG' says.
Comment 2 Michal Jaegermann 2003-02-08 20:16:13 EST
Indeed, with 'newt' from rawhide I can get some reaction and it
is possible to configure something.  OTOH readability is still not
that great and after selecting a button I see things like


on my screen.  Not a show-stopper but somewhat annoying.
Comment 3 Tim Waugh 2003-02-09 10:51:31 EST
I don't see this.  I see a perfectly normal display, with no glitches.  Please
tell me what you have for $LANG, and which VT you are using (1, or something else).
Comment 4 Michal Jaegermann 2003-02-09 12:37:01 EST
I tried with few different settings of LANG ranging between C and en_CA
with en_CA.utf8.  I did not see much of a difference.  OTOH my current
beta installation is partial due to a physical damage on one of received
CDs.  I will return to the issue later when I will have something more
akin to a "standard" setup.  OTOH if these displays are so "sensitive"
that this likely means that one will get into a trouble trying to use
configuration tools over a network without X.

"Doubling", like mentioned above, happens only on selected buttons and
follows you reverting to the original display when some other button is

I was running tests mostly on vt1 but I do not see anything different on vt2.
Comment 5 Eido Inoue 2003-09-10 14:14:36 EDT
I can't reproduce this either. Sometimes when I switch between graphics mode and
text consoles, I need to redo the "unicode_start" command to get the correct
line drawing characters, but once I do this, I can't see any of the problems
described in this report.

Note You need to log in before you can comment on or make changes to this bug.