Bug 836944 - Events - not all events are reported when removing vms
Events - not all events are reported when removing vms
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Eli Mesika
infra virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 05:42 EDT by Elena
Modified: 2014-01-12 20:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 04:03:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-07-02 05:42:03 EDT
When removing 10 vms simultaneously only 8-9 of events with type=36 are reported.
Found in automated rest api tests:
http://<hist>/api/events?search=type%3D36
Comment 2 Eli Mesika 2012-07-18 04:03:44 EDT
You should use type 113 for it, not 36 !!!

please note that type 36 only reports on removal initialization since the VM may have images to remove and that is an async operation.

The message format on type 36 is:
  Removal of VM <vm> was initiated by <user>.

while teh message format on type 113 is:
  VM <vm> was successfully removed.

Please allign your tests to use type 113 if you want to see which VMs completes removal (i.e. finished to remove also the VM images)

Note You need to log in before you can comment on or make changes to this bug.