Bug 836972 - Gnome-calculator help says it does not support complex numbers but it does
Gnome-calculator help says it does not support complex numbers but it does
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-calculator (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Alexander Larsson
Desktop QE
:
Depends On: 821425
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 07:15 EDT by Martin Simon
Modified: 2016-09-19 22:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 821425
Environment:
Last Closed: 2015-09-03 14:04:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 748730 None None None Never

  None (edit)
Description Martin Simon 2012-07-02 07:15:41 EDT
+++ This bug was initially created as a clone of Bug #821425 +++

Description of problem:
GCalcTool help says it does not support complex numbers but it does. The help should stay actual after feature updates.

Version-Release number of selected component (if applicable):
gcalctool-6.4.1.1-1.fc17.i686

How reproducible:
100%

Steps to Reproduce:
1. Press F1
2. Click Number -> complex numbers
3.
  
Actual results:
Complex numbers are not supported in GCalctool.

Expected results:
The help that explain the work with complex numbers in gcalctool because in Advanced mode there are several functions using complex numbers.

Additional info:
There is probably more feature/help inconsistency, I did not investigate that at all.
Comment 3 Martin Simon 2013-07-29 05:22:53 EDT
The bug is still present in gnome-calculator-3.8.2-1.el7.x86_64
Comment 4 RHEL Product and Program Management 2014-03-22 03:06:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Matthias Clasen 2015-04-30 23:16:15 EDT
Still the case in current release. I've filed an upstream bug.
Comment 7 Matthias Clasen 2015-09-03 14:04:56 EDT
realistically, the only chance that we're ever going to fix this is if an upstream fix comes in as part of a rebase.

Note You need to log in before you can comment on or make changes to this bug.