Bug 83698 - New kernel .config breaks SCSI installs
Summary: New kernel .config breaks SCSI installs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: ia64 Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 06:02 UTC by Martin K. Petersen
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-08 21:59:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin K. Petersen 2003-02-07 06:02:36 UTC
This is just a heads-up because you are likely to run into this at some point.

The recent errata kernels use dynamically linked CONFIG_SCSI and
CONFIG_BLK_DEV_SD.  The anaconda mk-images.ia64 script doesn't handle the latter
being a module, so SCSI disks can't be accessed during install when a recent
kernel image is used.

Trivial patch: http://mkp.net/patches/mk-images.diff

Comment 1 Jeremy Katz 2003-02-08 21:59:36 UTC
Yep, this is already done in rawhide anaconda


Note You need to log in before you can comment on or make changes to this bug.