Bug 837020 - Switch to finer grained dep on libvirt RPMs
Switch to finer grained dep on libvirt RPMs
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Douglas Schilling Landgraf
Haim
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 10:22 EDT by Daniel Berrange
Modified: 2014-01-12 19:52 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 06:17:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15760 None None None Never
oVirt gerrit 15761 None None None Never

  None (edit)
Description Daniel Berrange 2012-07-02 10:22:49 EDT
Description of problem:
Currently VDSM requires the following libvirt packages

  Requires: libvirt >= 0.9.10
  Requires: libvirt-python, libvirt-lock-sanlock

The 'libvirt' RPM dep was used to pull in libvirtd and its KVM driver. This also, however, pulls in libvirt's default NAT based network XML and default network filters definitions. I don't believe that VDSM requires either of these default config sets, and the NAT one in particular can cause trouble.

As of Fedora 17 we have a much more fine grained dependancy model for libvirt:

     - libvirt: just a virtual package with dep on libvirt-daemon,
       libvirt-daemon-config-network & libvirt-daemon-config-nwfilter
     - libvirt-daemon: the libvirt daemon and related pieces
     - libvirt-daemon-config-network: the default network config
     - libvirt-daemon-config-nwfilter: the network filter configs
     - libvirt-docs: the website HTML

We then introduce some more virtual (empty) packages
    
     - libvirt-daemon-qemu: Deps on libvirt-daemon & 'qemu'
     - libvirt-daemon-kvm: Deps on libvirt-daemon & 'qemu-kvm'
     - libvirt-daemon-lxc: Deps on libvirt-daemon
     - libvirt-daemon-uml: Deps on libvirt-daemon
     - libvirt-daemon-xen: Deps on libvirt-daemon & 'xen'

which provide a convenient way for apps like VDSM to depend on libvirt.

As of Fedora 18, we also split the actual drivers out into loadable modules, so libvirtd itself no long has a dep on xen-libs.

So for VDSM, which only cares about KVM, and not QEMU, it likely makes sense to replace  "Requires: libvirt" with "Requires: libvirt-daemon-kvm"

this will pull in libvirtd, the KVM driver module, and whatever RPM includes /usr/bin/qemu-kvm, and nothing else.

Version-Release number of selected component (if applicable):
vdsm-4.9.3.2-0.fc17
Comment 1 Dan Kenigsberg 2013-07-31 15:04:29 EDT
Note that since vdsm requires mom, and mom requires libvirt coarsely, the accepted patch has no useful effect until the mom part is taken in http://gerrit.ovirt.org/#/c/15760 .
Comment 2 Douglas Schilling Landgraf 2013-08-01 13:14:24 EDT
(In reply to Dan Kenigsberg from comment #1)
> Note that since vdsm requires mom, and mom requires libvirt coarsely, the
> accepted patch has no useful effect until the mom part is taken in
> http://gerrit.ovirt.org/#/c/15760 .

Thanks Dan, it has been merged today. Moving to MODIFIED again.

Note You need to log in before you can comment on or make changes to this bug.