Bug 837032 - xen: trivial hypervisor backports for 5.9
xen: trivial hypervisor backports for 5.9
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks: 768350
  Show dependency treegraph
 
Reported: 2012-07-02 10:50 EDT by Igor Mammedov
Modified: 2013-01-09 20:02 EST (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.18-325.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:38:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x86: emulate lea with two register operands correctly (1.21 KB, patch)
2012-07-02 12:47 EDT, Igor Mammedov
no flags Details | Diff
Fix #GPF injection into compat guests in vm86 code (1.36 KB, patch)
2012-07-02 12:47 EDT, Igor Mammedov
no flags Details | Diff

  None (edit)
Description Igor Mammedov 2012-07-02 10:50:34 EDT
A couple of safe patches to backport into 5.9. taken from Bug 768350 comments 3, 6.

- xen-unstable c/s 24456, x86: emulate lea with two register operands correctly

- Fix #GPF injection into compat guests in vm86 code
  http://xenbits.xensource.com/hg/xen-3.4-testing.hg/rev/14709d196e43
Comment 1 Igor Mammedov 2012-07-02 12:47:23 EDT
Created attachment 595771 [details]
x86: emulate lea with two register operands correctly
Comment 2 Igor Mammedov 2012-07-02 12:47:57 EDT
Created attachment 595772 [details]
Fix #GPF injection into compat guests in vm86 code
Comment 3 RHEL Product and Program Management 2012-07-03 06:09:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 6 Qin Guan 2012-11-05 04:45:52 EST
Testing of this problem is covered by running acceptance/functional testing with
several Snapshot builds (from Snapshot1 to Snapshot5) on different CPU models. 

No any problem found during the testing, marked it as Verified:SanityOnly.
Comment 8 errata-xmlrpc 2013-01-07 23:38:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0006.html

Note You need to log in before you can comment on or make changes to this bug.