Bug 837043 - add php(language) virtual provide
add php(language) virtual provide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Web Stack Team
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 11:09 EDT by Joe Orton
Modified: 2013-09-04 05:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837042
Environment:
Last Closed: 2013-09-04 05:45:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2012-07-02 11:09:24 EDT
+++ This bug was initially created as a clone of Bug #837042 +++

Description of problem:
Third-party (e.g. EPEL) and Fedora packaging requires a "virtual" provide for the PHP language version, independent of the specific php packages which are installed.  We are using "php(language) = version" for this; this should be added to the php packages in Red Hat Enterprise Linux so third-party packagers can produce consistently packaged PHP libraries (and web applications) for Fedora and RHEL.

Version-Release number of selected component (if applicable):
php-5.3.3-14.el6_3

How reproducible:
always

Steps to Reproduce:
1. rpm -q --provides php-common | grep 'php(language)'
  
Actual results:
nada

Expected results:
5.3.3
Comment 1 RHEL Product and Program Management 2012-07-02 11:27:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2013-05-01 03:16:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.