Bug 837045 - s-c-cluster tracebacks with unsupported fencing device
s-c-cluster tracebacks with unsupported fencing device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.9
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 11:11 EDT by Radek Steiger
Modified: 2013-01-08 02:23 EST (History)
1 user (show)

See Also:
Fixed In Version: system-config-cluster-1.0.57-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:23:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Steiger 2012-07-02 11:11:53 EDT
Description of problem:

system-config-cluster will not allow to configure fencing when a fencing device is added, that is supported by the cluster, but not by system-config-cluster itself. Having such a fence device in cluster.conf makes system-config-cluster to produce a non-fatal traceback and refuses to show any configuration options for that device, or for fencing devices in general.


Version-Release number of selected component (if applicable):

system-config-cluster-1.0.57-15


How reproducible:

Always


Steps to Reproduce:

1. Define  a cluster that utilizes any of fencing devices not supported by s-c-cluster, i.e. "fence_rhevm":
<fencedevices>
  <fencedevice agent="fence_rhevm" ipaddr="10.20.30.40" login="rhev" name="rhev" passwd="rhev"/>
</fencedevices>
2. Open system-config-cluster
3. Try to open Fence Options or the fence device itself


Actual results:

Properties window will not show the requested content and a traceback is given to a terminal window (see below).


Expected results:

Being able to configure fencing with Fence Options menu.


Additional info:

** Traceback given by clicking on Fence Options menu: **

Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTab.py", line 157, in on_tree_selection_changed
    self.prop_renderer.render_to_layout_area(obj.getProperties(), FENCEDEVICES,type) 
  File "/usr/share/system-config-cluster/FenceDevices.py", line 44, in getProperties
    stringbuf = stringbuf + "%d - " % num + fence_opts[kee] + " " + TYPE
KeyError: u'fence_rhevm'

** Traceback given by clicking on 'rhev' fencing device: **

Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ConfigTab.py", line 163, in on_tree_selection_changed
    self.prop_renderer.render_to_layout_area(obj.getProperties(), obj.getName(),type) 
  File "/usr/share/system-config-cluster/FenceDevice.py", line 27, in getProperties
    pretty_fence_type = self.pretty_fence_names[agent_type]
KeyError: u'fence_rhevm'
Comment 1 RHEL Product and Program Management 2012-07-02 11:27:30 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 errata-xmlrpc 2013-01-08 02:23:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0046.html

Note You need to log in before you can comment on or make changes to this bug.