Bug 83705 - ethernet connection should continuously look for a DHCP server
ethernet connection should continuously look for a DHCP server
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-07 05:00 EST by Julien Olivier
Modified: 2014-03-16 22:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 14:28:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Olivier 2003-02-07 05:00:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
I wishit was possible to have a daemon looking for an available DHCP server. If
one is found, it would automatically start an ethernet connection to this DHCP
server. It's (AFAIK) the way Windows handles local network connection.

Currently, you can set up a network connection using DHCP and tell RedHat to
start it upon start. The problem is that if your cable wasn't plugged (or the
DHCP server not up) upon start, the connection won't be established and you'll
have to start it manually later. I think the reconnection should be automatic
(as an option maybe).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N.A.

Additional info:
Comment 1 Harald Hoyer 2003-02-10 06:23:19 EST
reassigning to initscripts
Comment 2 Pekka Savola 2003-07-22 06:29:53 EDT
FWIW, I think this would be better worded as "we should have a daemon looking
for a cable being plugged in" i.e. ethernet link state watcher which could then
run some events.
Comment 3 Bill Nottingham 2003-09-03 21:47:48 EDT
There actually are a couple of these daemons now.
Comment 4 Robert de Rooy 2003-09-22 13:57:06 EDT
Actually, that is not what windows does.

If the link is down, it will wait until link becomes available. We can do the 
same thing with /sbin/hotplug, it is just not implemented right now.

If the link is up, but no DHCP server is available it will time out and set 
a 'link-local' address in the 169.254/16 range. This is part of zeroconf and 
it would be nice if Red Hat Linux (or should I say Fedora) could do the same 
thing. 'Linux Magazine' issue August 2003 (not yet available online) has a 
nice article on page 16 about this.
Basically what happens is that windows tries to use the first address in the 
link-local range, and if it clashes takes the next one up until it gets a free 
address.

Other parts of ZEROCONF are Name Resolution and Service Discovery, the problem 
with these is that there are different parties that currently do not agree on 
how to do it.

For more info check out http://zeroconf.sourceforge.net/
Comment 5 Bill Nottingham 2005-09-30 14:28:23 EDT
This is handled currently by NetworkManager; further complication in initscripts
won't be added.

Note You need to log in before you can comment on or make changes to this bug.