Bug 837085 - startup script in strongswan-4.6.2-1.el6.x86_64 has wrong config path
startup script in strongswan-4.6.2-1.el6.x86_64 has wrong config path
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: strongswan (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Šimerda (pavlix)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 13:43 EDT by Aleks B
Modified: 2014-01-26 11:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-26 11:37:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to solve the problem (339 bytes, application/octet-stream)
2012-07-02 13:43 EDT, Aleks B
no flags Details

  None (edit)
Description Aleks B 2012-07-02 13:43:37 EDT
Created attachment 595785 [details]
patch to solve the problem

Description of problem:
There is wrong config path for variable in init.d script

Version-Release number of selected component (if applicable):
4.6.2-1

How reproducible:
service strongswan start
echo $?

Steps to Reproduce:
1.start strongswan
2.check error code (ie =6)

Actual results:
service fails to start

Expected results:
service starts

Additional info:
Comment 1 Aleks B 2012-07-09 14:17:32 EDT
Still present in 4.6.4-1
Comment 2 Pavel Šimerda (pavlix) 2012-11-01 20:37:40 EDT
Looks like it's fixed in the current master and possibly by some of the earlier testing-updates. I'm going to issue a new update soon, it will be version 5.0.1
but backwards compatibility should not be an issue here.
Comment 3 Pavel Šimerda (pavlix) 2012-11-20 15:41:43 EST
I couldn't issue an update as it currently doesn't build for EPEL. Unfortunately,
I don't have much time, that's why it's still not done.

http://koji.fedoraproject.org/koji/packageinfo?packageID=13302

Note You need to log in before you can comment on or make changes to this bug.