Bug 837096 - RFE: Handle FITRIM in md raid
RFE: Handle FITRIM in md raid
Status: CLOSED DUPLICATE of bug 714644
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jes Sorensen
Red Hat Kernel QE team
:
Depends On:
Blocks: 837097 974315 1023424
  Show dependency treegraph
 
Reported: 2012-07-02 14:37 EDT by Eric Sandeen
Modified: 2013-10-25 07:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 837097 (view as bug list)
Environment:
Last Closed: 2012-07-13 05:13:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2012-07-02 14:37:55 EDT
The current MD driver does not pass FITRIM (trim/discard) commands down to the underlying devices, so a mirror or raid of SSDs cannot be trimmed with offline tools such as "fstrim" (and I presume online trim, i.e. mount -o discard probably won't work either).

dm was fixed a while ago, it seems that md should handle this too.

-Eric
Comment 1 Jes Sorensen 2012-07-13 05:13:40 EDT

*** This bug has been marked as a duplicate of bug 714644 ***

Note You need to log in before you can comment on or make changes to this bug.