Bug 837102 - ecl missing Requires: libffi-devel ?
ecl missing Requires: libffi-devel ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ecl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 821188
  Show dependency treegraph
 
Reported: 2012-07-02 15:35 EDT by Rex Dieter
Modified: 2012-07-03 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 09:42:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-07-02 15:35:55 EDT
So, was trying to build maxima against ecl today, and it failed with:

...
;;;
;;; Compiling /builddir/build/BUILD/maxima-5.27.0/src/maxima-package.lisp.
;;; OPTIMIZE levels: Safety=2, Space=0, Speed=3, Debug=2
;;;
;;; End of Pass 1.
;;; Finished compiling /builddir/build/BUILD/maxima-5.27.0/src/maxima-package.lisp.
;;;
/usr/bin/ld: cannot find -lffi
collect2: error: ld returned 1 exit status

Perhaps ecl is missing
Requires: libffi-devel
?
Comment 1 Rex Dieter 2012-07-03 09:42:30 EDT
fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.