Bug 837122 - Macaulay2 is FTBFS on ARM
Summary: Macaulay2 is FTBFS on ARM
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Macaulay2
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 842407
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2012-07-02 21:20 UTC by Peter Robinson
Modified: 2014-05-05 14:26 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-05-05 14:26:15 UTC


Attachments (Terms of Use)

Description Peter Robinson 2012-07-02 21:20:55 UTC
Macaulay2 is FTBFS on ARM

List of all failures:
http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=92

Latest failure:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=938380

** compiling gb-test1.cpp
 ** compiling finalize.cpp
finalize.cpp: In function 'void remove_monideal(void*, void*)':
finalize.cpp:34:56: error: 'AO_fetch_and_add1' was not declared in this scope
compilation terminated due to -Wfatal-errors.
make[2]: *** [finalize.o] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/Macaulay2-1.4-r12617/Macaulay2/e'
make[1]: Leaving directory `/builddir/build/BUILD/Macaulay2-1.4-r12617/Macaulay2'
make: Leaving directory `/builddir/build/BUILD/Macaulay2-1.4-r12617'
make[1]: *** [all-in-e] Error 2
make: *** [all-in-Macaulay2] Error 2

Comment 1 Rex Dieter 2012-08-07 14:37:52 UTC
OK, looks like this will need some libatomic_ops love for platforms with out native implementations of those calls

Comment 2 Gwyn Ciesla 2012-09-24 16:46:42 UTC
This wants factory-devel >= 3.1.4, rawhide factory is 3.1.1.

Comment 3 Rex Dieter 2012-09-24 16:58:28 UTC
fyi, libfac and factory now gets built from Singular

Comment 4 Gwyn Ciesla 2012-09-24 17:06:17 UTC
Which isn't in f17, which totally explains my confusion. :)  Thanks.

Comment 5 Fedora End Of Life 2013-04-03 17:13:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19


Note You need to log in before you can comment on or make changes to this bug.