Bug 837227 - 6.3 regression in bnx2 driver when used in bond [rhel-6.3.z]
6.3 regression in bnx2 driver when used in bond [rhel-6.3.z]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Linux
urgent Severity high
: rc
: ---
Assigned To: Frantisek Hrbata
Red Hat Kernel QE team
: ZStream
Depends On: 834764
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 04:59 EDT by RHEL Product and Program Management
Modified: 2012-12-19 09:59 EST (History)
26 users (show)

See Also:
Fixed In Version: kernel-2.6.32-279.2.1.el6
Doc Type: Bug Fix
Doc Text:
The bonding method for adding VLAN Identifiers (VIDs) did not always add the VID to a slave VLAN group. When the NETIF_F_HW_VLAN_FILTER flag was not set on a slave, the bonding module could not add new VIDs to it. This could cause networking problems and the system to be unreachable even if NIC messages did not indicate any problems. This update changes the bond VID add path to always add a new VID to the slaves (if the VID does not exist). This ensures that networking problems no longer occur in this scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 15:45:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 161033 None None None 2012-07-14 14:18:34 EDT

  None (edit)
Description RHEL Product and Program Management 2012-07-03 04:59:00 EDT
This bug has been copied from bug #834764 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 7 Eliska Slobodova 2012-07-17 10:20:43 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The bonding method for adding VLAN Identifiers (VIDs) did not always add the VID to a slave VLAN group. When the NETIF_F_HW_VLAN_FILTER flag was not set on a slave, the bonding module could not add new VIDs to it. This could cause networking problems and the system to be unreachable even if NIC messages did not indicate any problems. This update changes the bond VID add path to always add a new VID to the slaves (if the VID does not exist). This ensures that networking problems no longer occur in this scenario.
Comment 9 Liang Zheng 2012-07-18 23:32:04 EDT
QE Note:
Regression test is done , all the test are PASS.
The NIC we have tested:
bnx2,igb.e1000e,cxgb4,be2net,bnx2x,ixgbe,bna,sfc
The test items :
1. Connection test (all 7 bond modes)
Beaker job link in Comment 6
2. Jambo Frame test (mtu 9000)
https://beaker.engineering.redhat.com/jobs/263095
3. tcp/udp/igmp/sctp (ipv4/ipv6) protocol test
In Comment 8 & https://beaker.engineering.redhat.com/jobs/262752
4. loop change active slave test (each slave)
change_active_slave task in https://beaker.engineering.redhat.com/jobs/262968
5. loop load/unload bonding and 8021q module test (100 times)
6. Bonding Tier1 Test (arp_monitor  bond_bridge_dhcp  bond_bridge_lro  bond_dhcp  module_load_unload)
https://beaker.engineering.redhat.com/jobs/262750

Ref : https://wiki.test.redhat.com/Kernel/Testplans/RHEL59bonding
Comment 10 Liang Zheng 2012-07-18 23:38:10 EDT
(In reply to comment #9)
> QE Note:
> Regression test is done , all the test are PASS.
> The NIC we have tested:
> bnx2,igb.e1000e,cxgb4,be2net,bnx2x,ixgbe,bna,sfc 
+ tg3
> The test items :
> 1. Connection test (all 7 bond modes)
> Beaker job link in Comment 6
> 2. Jambo Frame test (mtu 9000)
> https://beaker.engineering.redhat.com/jobs/263095
> 3. tcp/udp/igmp/sctp (ipv4/ipv6) protocol test
> In Comment 8 & https://beaker.engineering.redhat.com/jobs/262752
> 4. loop change active slave test (each slave)
> change_active_slave task in https://beaker.engineering.redhat.com/jobs/262968
> 5. loop load/unload bonding and 8021q module test (100 times)
> 6. Bonding Tier1 Test (arp_monitor  bond_bridge_dhcp  bond_bridge_lro 
> bond_dhcp  module_load_unload)
> https://beaker.engineering.redhat.com/jobs/262750
> 
> Ref : https://wiki.test.redhat.com/Kernel/Testplans/RHEL59bonding
Comment 12 errata-xmlrpc 2012-07-19 15:45:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1104.html

Note You need to log in before you can comment on or make changes to this bug.