This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 837228 - Redundant "XXX" occurs on ovirt.log when register to RHN with invalid password
Redundant "XXX" occurs on ovirt.log when register to RHN with invalid password
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: Regression
Depends On:
Blocks: 840699
  Show dependency treegraph
 
Reported: 2012-07-03 05:00 EDT by shaochen
Modified: 2016-04-26 11:24 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-7.el6
Doc Type: Bug Fix
Doc Text:
Previously, when subscribing to the Red Hat Network, a failed subscription attempt would cause ovirt.log to fill with redundant characters. This has been fixed so that when attempting to subscribe fails, the correct error message appears in the log.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:37:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shaochen 2012-07-03 05:00:27 EDT
Description of problem:
Redundant "XXX" occurs on ovirt.log when register to RHN with invalid username or password.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120702.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H and configure network.
2. Register to RHN with invalid username or password (e.g. username: 111 password: 111)
3. Check /var/log/ovirt.log
  
Actual results:
1. Register to RHN failed and redundant "XXX" occurs on ovirt.log.
2. Register to RHN can successful with correct username and password, and no  redundant "XXX" occurs on ovirt.log.

ovirt.log
==============================
2012-07-03 07:30:14,489 - DEBUG - ovirtfunctions - 
2012-07-03 07:30:14,489 - INFO - rhn - Registering to RHN account.....
2012-07-03 07:30:14,508 - DEBUG - rhn - XXXXXXXX[XXXXXXXX'XXXXXXXX/XXXXXXXXuXXXXXXXXsXXXXXXXXrXXXXXXXX/XXXXXXXXsXXXXXXXXbXXXXXXXXiXXXXXXXXnXXXXXXXX/XXXXXXXXrXXXXXXXXhXXXXXXXXnXXXXXXXXrXXXXXXXXeXXXXXXXXgXXXXXXXX_XXXXXXXXkXXXXXXXXsXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXX-XXXXXXXX-XXXXXXXXuXXXXXXXXsXXXXXXXXeXXXXXXXXrXXXXXXXXnXXXXXXXXaXXXXXXXXmXXXXXXXXeXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXXqXXXXXXXXaXXXXXXXX@XXXXXXXXrXXXXXXXXeXXXXXXXXdXXXXXXXXhXXXXXXXXaXXXXXXXXtXXXXXXXX.XXXXXXXXcXXXXXXXXoXXXXXXXXmXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXX-XXXXXXXX-XXXXXXXXpXXXXXXXXaXXXXXXXXsXXXXXXXXsXXXXXXXXwXXXXXXXXoXXXXXXXXrXXXXXXXXdXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXX-XXXXXXXX-XXXXXXXXnXXXXXXXXoXXXXXXXXvXXXXXXXXiXXXXXXXXrXXXXXXXXtXXXXXXXXiXXXXXXXXnXXXXXXXXfXXXXXXXXoXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXX-XXXXXXXX-XXXXXXXXnXXXXXXXXoXXXXXXXXrXXXXXXXXhXXXXXXXXnXXXXXXXXsXXXXXXXXdXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXX-XXXXXXXX-XXXXXXXXnXXXXXXXXoXXXXXXXXpXXXXXXXXaXXXXXXXXcXXXXXXXXkXXXXXXXXaXXXXXXXXgXXXXXXXXeXXXXXXXXsXXXXXXXX'XXXXXXXX,XXXXXXXX XXXXXXXX'XXXXXXXX-XXXXXXXX-XXXXXXXXfXXXXXXXXoXXXXXXXXrXXXXXXXXcXXXXXXXXeXXXXXXXX'XXXXXXXX]XXXXXXXX
2012-07-03 07:30:22,817 - DEBUG - rhn - Error validating data at server:

Error Message:
    Invalid username/password combination


Expected results:
1. Ovirt.log can report the failed reason without redundant characters.

Additional info:
No such issue in rhev-hypervisor6-6.3-20120621.0.el6_3, so it is a regression bug.

ovirt.log on rhev-hypervisor6-6.3-20120621.0.el6_3
=============================================================
2012-07-03 08:17:07,433 - INFO - rhn - Registering to RHN account.....
2012-07-03 08:17:07,444 - DEBUG - rhn - ['/usr/sbin/rhnreg_ks', '--username', 'XXXXXXXX', '--password', 'XXXXXXXX', '--novirtinfo', '--norhnsd', '--nopackages', '--force']
2012-07-03 08:17:15,435 - DEBUG - rhn - Error validating data at server:
Error Message:
    Invalid username/password combination
Comment 2 Fabian Deutsch 2012-07-03 05:27:09 EDT
This problem appears when password or proxypass are empty, then all spaces between chars are filled with the pattern.

Try:
for password in ["TEST", ""]:
  args =["abc", "def", password, "foo"]
  print (str(args).replace(password, "XXXXX"))
Comment 5 Fabian Deutsch 2012-10-12 10:02:56 EDT
http://gerrit.ovirt.org/#/c/8515/
Comment 12 errata-xmlrpc 2013-02-28 11:37:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.