This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 837260 - RFE: Notify project maintainer/s of updates to project translations
RFE: Notify project maintainer/s of updates to project translations
Status: CLOSED DUPLICATE of bug 1092810
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On: 1117633
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 06:21 EDT by Parag Nemade
Modified: 2015-08-06 01:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-23 21:03:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2012-07-03 06:21:40 EDT
Description of problem:
I see that some translators updated their translation po files but I didn't get any notification for that in my mailbox. Please provide a UI option for project maintainers so that whoever want to get notification for translations submitted by translators will get it in their registered email.

Version-Release number of selected component (if applicable):
zanata-python-client-1.3.5-1.fc17.noarch
zanata python client version: 1.3.5, zanata server API version: 1.5.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Runa Bhattacharjee 2012-07-30 08:33:34 EDT
Technical evaluation requested.
Comment 2 Parag Nemade 2012-12-26 04:32:47 EST
Can anyone check what is the update for this issue? is this resolved or deferred or denied? I have not yet got any update since last 5 months.
Comment 3 Ding-Yi Chen 2013-01-02 19:04:41 EST
We do have plan for notification like this in 3.0.
Comment 4 Parag Nemade 2013-09-10 12:07:28 EDT
Can anyone check what is the update for this issue? is this resolved or deferred or denied?
Comment 5 Alex Eng 2013-09-10 17:52:19 EDT
Parag,
The notification feature is definitely in our todo list. 
Currently its in our backlog waiting to be prioritized.  

I've assigned this bug to our product owner.
Comment 6 Damian Jansen 2014-02-28 01:03:55 EST
There would have to be some serious thought as to the "when" of notifying the maintainer. Some projects might have hundreds of translation updates a day.

UI for config'n:
- who receives
- immediate, or <time> digest
- do we allow selection of versions to report on?
- does this feature apply to groups?
Comment 7 Sean Flanigan 2014-02-28 01:32:13 EST
Perhaps maintainer options to:

 - notify me once per week/day if there are updated translations to pull
 - notify me immediately/daily/weekly if any locale reaches 100% translated

The UI should make it clear which email address will be notified (ie show email address from profile)
Comment 8 Luke Brooker 2014-03-02 18:31:27 EST
Notification are not something we should tack on or add lightly. There are more than just one use case for notifications, so a global notifications system needs to be in place which can all be handled from the users settings.

We should be very careful before adding custom notifications to each project as it could easily become overly complicated for maintainers of many projects to find out why they are getting certain notifications if they are all different.

Even if we do add custom notifications per project this should probably still be handled from the users settings with a list of their projects. But firstly there should be a global notification setting for maintained projects.
Comment 9 Parag Nemade 2014-06-04 04:09:53 EDT
any updates here?
Comment 10 Luke Brooker 2015-01-11 19:49:51 EST
We are looking at a larger "notifications system" in the following bugs:

- Bug 1092810 - RFE: Implement a Zanata notification system (notifications to users)
- Bug 1117633 - RFE: Add basic user notification system

We will keep those bugs up to date with progress
Comment 11 Michelle Kim 2015-02-23 21:03:04 EST
Notification is important feature, so we will keep one epic bug 1156236 to keep track of all the notification implementation. This bug is closed as it is part of the parent bug.

*** This bug has been marked as a duplicate of bug 1092810 ***
Comment 12 Michelle Kim 2015-02-24 19:13:57 EST
My previous comment refer to wrong bug number. 
The parent bug number is 1092810   not 1156236

(In reply to Michelle Kim from comment #11)
> Notification is important feature, so we will keep one epic bug 1156236 to
> keep track of all the notification implementation. This bug is closed as it
> is part of the parent bug.
> 
> *** This bug has been marked as a duplicate of bug 1092810 ***

Note You need to log in before you can comment on or make changes to this bug.