Bug 837277 - [RFE ]Test Connection button should be disabled for blank proxy field.
[RFE ]Test Connection button should be disabled for blank proxy field.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-07-03 07:03 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 15:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-07-03 07:03:58 EDT
Prerequisites : 
Rhel5.9 with latest subscription-manager

Steps to verify : 
Launch subscription-manager-gui. 
check HTTP Proxy.
Don't update proxy location field.

Expected Result : 
Test Connection button should be disabled for blank proxy field.
Comment 1 spandey 2012-07-03 07:14:43 EDT
Got this issue with following subscription-manager rpm 

subscription-manager-migration-1.0.7-1.git.10.4c364f3.el5
subscription-manager-gui-1.0.7-1.git.10.4c364f3.el5
subscription-manager-firstboot-1.0.7-1.git.10.4c364f3.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-1.0.7-1.git.10.4c364f3.el5
Comment 2 Bryan Kearney 2012-07-30 13:34:08 EDT
triaging
Comment 4 Tom Lavigne 2012-09-07 11:24:48 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 5 Bryan Kearney 2013-10-09 15:10:17 EDT
It enables only when the option is selected, and then warns you if blank. I am fine with the current behaviour.

Note You need to log in before you can comment on or make changes to this bug.