Bug 83737 - cannot handle file 'libc.so.6' with TLS data
Summary: cannot handle file 'libc.so.6' with TLS data
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: athlon Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 18:44 UTC by Kim Bisgaard
Modified: 2016-11-24 15:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 22:21:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kim Bisgaard 2003-02-07 18:44:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
I am running with RedHat 8.0 with selected rawhide updates - and this wednsday I
upgraded glibc and binutils from rawhide. After that RPM stops after
"Preparing..." has reached 100% with the following error:
cannot handle file 'libc.so.6' with TLS data


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Fvh glibc-2.3.1-41.i686.rpm

    

Actual Results:  Preparing...               
########################################### [100%]
cannot handle file 'libc.so.6' with TLS data


Expected Results:  get my rpm's installed

Additional info:

glibc-2.3.1-40

RedHat 8.0 with upgrades to rawhide of gcc,binutils,glibc,kde,xfree.

Comment 1 Michael Young 2003-02-07 21:35:36 UTC
I suspect this is the first attempt to use rpm since you upgraded from the 8.0
glibc, and your problem is that rpm isn't new enough.

Comment 2 Jakub Jelinek 2003-02-07 22:21:03 UTC
You need to upgrade at least all statically linked applications which use NSS
or iconv (ie. dlopen shared libraries).

Comment 3 Kim Bisgaard 2003-02-09 10:50:13 UTC
Thanks for the help!

Isen't that a bug with regard to some dependency?

Do you have an idea on how to:
1. identify which applications that is? except from rpm
2. how to upgrade them when rpm does not work?

Best regards,
Kim

Comment 4 Michael Young 2003-02-10 10:26:47 UTC
You could have dug yourself into a hole it is not easy to escape from! Setting
the environment variable LD_ASSUME_KERNEL=2.2.5 is worth a try; it turns off TLS
in some cases, though I don't know if it will work in this one. Otherwise you
could boot off your CD in rescue mode; run linux rescue at the boot prompt, and
install the necessary packages that way, though the simplest way is probably to
download the phoebe beta CDs, and upgrade completely to the beta.


Note You need to log in before you can comment on or make changes to this bug.