Bug 837375 - IPA error message for targetattr is not formatted.
IPA error message for targetattr is not formatted.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 12:06 EDT by Dmitri Pal
Modified: 2012-10-10 08:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 08:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-07-03 12:06:29 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2873

Version: freeipa-server-2.99.0-0.20120618T1103Zgite94733f.fc17.x86_64

# ipa permission-mod APermission --rename=ABCPermission --attrs --permissions=write --type=user

ipa: ERROR: targetattr "--permissions=write" does not exist in schema. Please add attributeTypes "--permissions=write" to schema if necessary. ACL Syntax Error(-5):(targetattr = \22--permissions=write\22)(target = \22ldap:///uid=\2a,cn=users,cn=accounts,dc=testrelm,dc=com\22)(version 3.0;acl \22permission:APermission\22;allow (write) groupdn = \22ldap:///cn=apermission,cn=permissions,cn=pbac,dc=testrelm,dc=com\22;): Invalid syntax.
[root@dhcp201-207 ipa-rbac]#



{{{
<shanks> mkosek, see "\22" in the output
<mkosek> shanks: hello, you mean the fact that \22 is in the output not the that the command does not work?
<mkosek> shanks: because the options are indeed wrong, --attrs takes value
<shanks> mkosek, yes, this was part of negative testing
<mkosek> shanks: well, there is a indeed some glitch in the error message, you can file a bug if you want to - though this is a very low priority one :)
<shanks> mkosek, ok, thanks
}}}
Comment 1 RHEL Product and Program Management 2012-07-10 04:09:07 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:29:46 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Martin Kosek 2012-09-26 02:49:03 EDT
I investigated this issue and I found that the error message is actually OK and expected, backslash hex escapes are intended. This exact error message would also be returned if somebody adds such ACL breaking the DS syntax (unknown attribute) in other client tools, like ldapsearch. It can be also found in this format in Directory Server error log:

[25/Sep/2012:06:12:03 -0400] NSACLPlugin - ACL Syntax Error(-5):(targetattr = \22foo\22)(target =       \22ldap:///uid=\2a,cn=users,cn=accounts,dc=idm,dc=lab,dc=bos,dc=redhat,dc=com\22)(version 3.0;acl       \22permission:foo2\22;allow (write) groupdn = \22ldap:///cn=foo2,cn=permissions,cn=pbac,dc=idm,dc=lab,  dc=bos,dc=redhat,dc=com\22;)

Thus, since this is not a bug in IPA and the error message format is expected, I would like to close this bug as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.