Bug 837382 - [RFE] Range Web UI
[RFE] Range Web UI
Status: CLOSED DUPLICATE of bug 767723
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 12:19 EDT by Dmitri Pal
Modified: 2012-07-17 14:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 14:06:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-07-03 12:19:02 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2894

We have new range plugin. Web UI lacks this feature.
Comment 1 RHEL Product and Program Management 2012-07-10 04:08:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:30:06 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Jenny Galipeau 2012-07-13 10:47:35 EDT
What is this new feature?  What does this change in the WebUI?
Comment 4 Petr Vobornik 2012-07-13 11:03:20 EDT
It adds new functionality - complete support for new Range entity.

That basically means:
 * new menu item (probably in 'IPA Server' tab)
 * new search page
 * new details page - read-only, range doesn't have mod command

Range object is quite simple. It consists of:
 * (str) Range name 
 * (int) First Posix ID of the range
 * (int) Number of IDs in the range
 * (int) First RID of the corresponding RID range
 * (int) First RID of the secondary RID range
 * (str) Domain SID of the trusted domain

I doesn't have any special action or association, so the UI should be simple.
Comment 5 Jenny Galipeau 2012-07-17 14:06:34 EDT
This is part of the IPA Trust Effort will be addressed with the new feature - this is not a bug or additional RFE 

duplicate of :: https://bugzilla.redhat.com/show_bug.cgi?id=767723

*** This bug has been marked as a duplicate of bug 767723 ***

Note You need to log in before you can comment on or make changes to this bug.