Bug 837392 - RFE: 'rhc app create' should allow me to create an app directly from a quickstart URL
RFE: 'rhc app create' should allow me to create an app directly from a quicks...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 13:28 EDT by Brett Lentz
Modified: 2015-05-14 21:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 15:19:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Lentz 2012-07-03 13:28:02 EDT
When creating a new app on Openshift, using a quickstart is still a multistep process from the CLI. It involves creating the app, adding any additional cartridges that the app depends on, then merging the quickstart repo and deploying that merged repo up to OpenShift.

It would improve the user experience significantly if I could do the following in a single step:

$ rhc app create -a new-drupal-app --quickstart=git://github.com:openshift/drupal-example.git

The expected behavior would be for rhc to create the app, add any necessary cartridges, and then merge in the specified quickstart URL and push/deploy it to my new app. 

I suspect the quickstart would need to define it's app type and cartridge dependencies in order to accomplish this.
Comment 1 Rob Millner 2012-07-03 14:01:09 EDT
Cool feature - but this looks like a user story rather than a bug.

We have templates which can be launched via the REST API comprised of a few of the quickstart applications.  Enabling launching existing templates from the command line tools may be a good first step.
Comment 2 Clayton Coleman 2012-07-12 15:19:44 EDT
https://rally1.rallydev.com/#/4670513817d/detail/userstory/7105449163

Opened a story to cover the UI aspects of this, we already have another story in the runtime backlog to track creating an app directly from a git repo that Fotios created.

Note You need to log in before you can comment on or make changes to this bug.