Bug 837469 - The build type in jenkins page is wrong for ruby-1.9 jenkins build
The build type in jenkins page is wrong for ruby-1.9 jenkins build
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 23:21 EDT by Rony Gong
Modified: 2015-05-14 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: jenkins-plugin-openshift 0.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-07-03 23:21:32 EDT
Description of problem:


Version-Release number of selected component (if applicable):
devenv_1874

How reproducible:
always

Steps to Reproduce:
1.create a ruby-1.9 app, enable jenkins 
2.do jenkins build by git push
3.go to https://qjenkins-qgong5.dev.rhcloud.com/job/q1ruby19-build/configure
check the item "build type"
  
Actual results:
"build type" default set as "diy-0.1"


Expected results:
"build type" should default set as "ruby-1.9"

Additional info:
Comment 1 Jianwei Hou 2012-08-29 01:56:45 EDT
Checked latest devenv(devenv_2091), now we have jenkins-plugin-openshift-0.6.0-0.el6_3.x86_64, since version is lower than fixed version, we will leave the bug ON_QA until we get latest fix.
Comment 2 Jianwei Hou 2012-08-30 03:03:15 EDT
Verified on devenv_2096

Steps:
1. Create a ruby-1.9 application and embed jenkins-client-1.4
2. In app's repo, make some change and git push
3. On jenkins webconsole, check the builder type for ruby-1.9 application

Result:
Jenkins build is successful, builder type is ruby-1.9 as default.

Note You need to log in before you can comment on or make changes to this bug.