Bug 837472 - nut-driver.service not restarted after package upgrade
nut-driver.service not restarted after package upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 23:41 EDT by Jordan Russell
Modified: 2012-09-21 20:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: nut-2.6.5-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 20:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2012-07-03 23:41:03 EDT
Description of problem:
nut-driver.service is not restarted automatically when the nut packages are upgraded.

On Fedora 15, with the old 'ups' init script, the driver did get restarted.

Version-Release number of selected component (if applicable):
2.6.4-1.fc16
Comment 1 Michal Hlavinka 2012-09-11 10:57:48 EDT
Fixed, but because the restart happens in %postun section, it will start working when the fixed package is updated with some newer one.
Comment 2 Fedora Update System 2012-09-11 11:23:39 EDT
nut-2.6.5-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nut-2.6.5-3.fc17
Comment 3 Fedora Update System 2012-09-11 11:23:56 EDT
nut-2.6.5-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nut-2.6.5-3.fc16
Comment 4 Fedora Update System 2012-09-11 20:23:57 EDT
Package nut-2.6.5-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nut-2.6.5-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13821/nut-2.6.5-3.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-21 20:02:01 EDT
nut-2.6.5-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-09-21 20:11:09 EDT
nut-2.6.5-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.