Bug 837474 - dhcpd.leases initially created with wrong ownership
dhcpd.leases initially created with wrong ownership
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-04 00:02 EDT by Jordan Russell
Modified: 2012-08-06 03:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 03:57:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2012-07-04 00:02:20 EDT
Description of problem:
Each time dhcpd.service is (re)started, dhcpd.leases is recreated with root.root ownership instead of dhcpd.dhcpd. The incorrect ownership persists until dhcpd writes the leases again (hours later).

This doesn't seem to hurt the operation of dhcpd, but it does cause "rpm -V dhcp" to report a UG (user+group) discrepancy on the leases file.

Version-Release number of selected component (if applicable):
dhcp-4.2.3-8.P2.fc16

How reproducible:
Always

Steps to Reproduce:
1. servicectl restart dhcpd.service
2. Check ownership of dhcpd.leases
  
Actual results:
root.root

Expected results:
dhcpd.dhcpd
Comment 1 Jiri Popelka 2012-07-04 04:20:09 EDT
Yes, I know about it and I already tried to change this but with no luck, see bug #765967, comment #1.

This is the least painful solution and I'm afraid we need to live with it.

Thanks for the report anyway.
Comment 2 Jordan Russell 2012-07-05 23:57:49 EDT
Could you please add "owner" and "group" to the list of %verify exclusions on the leases files, then?

i.e. %verify(not size md5 mtime owner group)

If the ownership changes are considered normal -- just as size/md5/mtime changes are -- then it seems appropriate for "rpm -V" to not report them.

The reason I care: I have a cron job that runs "rpm -Va" periodically and alerts me if any new discrepancies are found. The ownership flip-flop here keeps triggering unwanted alerts whenever I reboot or otherwise restart dhcpd.
Comment 3 Jiri Popelka 2012-07-09 13:04:11 EDT
Jordan, please test
https://koji.fedoraproject.org/koji/buildinfo?buildID=329625
Comment 4 Fedora Update System 2012-07-23 08:01:07 EDT
dhcp-4.2.4-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-6.fc17
Comment 5 Fedora Update System 2012-07-23 08:04:27 EDT
dhcp-4.2.3-9.P2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dhcp-4.2.3-9.P2.fc16
Comment 6 Fedora Update System 2012-07-23 16:27:36 EDT
Package dhcp-4.2.3-9.P2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.3-9.P2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11018/dhcp-4.2.3-9.P2.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-07-25 08:45:13 EDT
dhcp-4.2.4-7.P1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-7.P1.fc17
Comment 8 Fedora Update System 2012-07-25 08:46:21 EDT
dhcp-4.2.3-10.P2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dhcp-4.2.3-10.P2.fc16
Comment 9 Mike C 2012-07-29 05:21:20 EDT
 /var/lib/dhcpd.leases is still given root:root ownership if dhcpd.service is restarted. If ownership is changed to dhcpd:dhcpd then it is changed back to root:root when dhcpd is restarted.
Comment 10 Mike C 2012-07-29 05:25:45 EDT
The rpm -V dhcp does not report any discrepancy on the leases file but the file ownership remains incorrect. It is not clear if the "fix" was merely to stop the discrepancy report or actually fix the ownership problem?
Comment 11 Jiri Popelka 2012-07-30 06:03:20 EDT
As I stated in comment #1 I have no idea how to properly fix this ownership problem so this updates only brings what you suggested in comment #2, i.e. it makes 'rpm -V' stop complaining about owner/group of dhcpd.leases file.
Comment 12 Mike C 2012-07-30 09:52:21 EDT
No problem - I gave it positive karma anyway in bodhi - hopefully the new version will go through soon - it works fine for me.
Comment 13 Fedora Update System 2012-08-01 14:28:28 EDT
dhcp-4.2.4-9.P1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-08-06 03:50:42 EDT
dhcp-4.2.3-11.P2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.