Bug 837523 - Malformed fontconfig config file
Summary: Malformed fontconfig config file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cjkuni-uming-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 837550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-04 07:51 UTC by Akira TAGOH
Modified: 2012-09-07 02:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-21 02:51:21 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2012-07-04 07:51:47 UTC
Description of problem:

Still no changes in the behavior in the latest version of fontconfig,
but it now warns when <test> contains multiple values or <alias> contains
multiple <family>s. this is because the behavior isn't intuitive and
doesn't work as expected necessarily. So you better consider to fix it
to make clearer what you want to do with it.

For solution, if you are expecting OR operator with that rule, add more
<match>s or <alias>es. if you are expecting AND operator with that rule,
just add more <test>s in that <match>.

Version-Release number of selected component (if applicable):
cjkuni-uming-fonts-0.2.20080216.1-48.fc17.src.rpm

How to reproducible:
always

Steps to Reproduce:
1. install the fonts package
2. fc-match

Actual results:
Fontconfig warning: "/etc/fonts/conf.d/65-0-ttf-arphic-uming.conf", line 8: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-ttf-arphic-uming.conf", line 34: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/65-0-ttf-arphic-uming.conf", line 60: Having multiple values in <test> isn't supported and may not works as expected

Expected results:
no warnings

Comment 1 Peng Wu 2012-07-10 06:29:34 UTC
*** Bug 837550 has been marked as a duplicate of this bug. ***

Comment 2 Peng Wu 2012-07-10 07:33:12 UTC
Rebuilt for rawhide.

Comment 3 Fedora Update System 2012-07-12 02:21:44 UTC
cjkuni-uming-fonts-0.2.20080216.1-49.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cjkuni-uming-fonts-0.2.20080216.1-49.fc17

Comment 4 Fedora Update System 2012-07-12 18:58:51 UTC
Package cjkuni-uming-fonts-0.2.20080216.1-49.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cjkuni-uming-fonts-0.2.20080216.1-49.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10585/cjkuni-uming-fonts-0.2.20080216.1-49.fc17
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-07-21 02:51:21 UTC
cjkuni-uming-fonts-0.2.20080216.1-49.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Akira TAGOH 2012-09-07 02:26:08 UTC
Since the behavior itself isn't changed in fontconfig, it may also affects to f16 that is still supported in Fedora. so can you push an update for f16 too?


Note You need to log in before you can comment on or make changes to this bug.